[LIST]ordered list items after 32 are all '0'

VERIFIED DUPLICATE of bug 44709

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 44709
18 years ago
18 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: Chris Waterson)

Tracking

({css1, html4})

Trunk
x86
All
css1, html4
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

With an ordered list of more than 32 items, all items after the 32nd are 
numbered '0'

..
31 foo
32 bar
0  foo
0  bar
..

see URL.

Comment 1

18 years ago
I also see it with 2000-06-17-08 on Linux. Changing OS to All.

FYI it was working with 2000-06-13-14 on Linux, but not with 2000-06-16-11.
OS: Windows 2000 → All
WORKS CORRECTLY IN:
 * Win98 mozilla 2000-06-14-15-M17

DOES NOT WORK IN:
 * Win98 mozilla 2000-06-15-09-M17
Summary: ordered list items after 32 are all '0' → [LIST]ordered list items after 32 are all '0'
buster messed with list numbering then.  See his changes to nsBlockFrame.cpp to 
fix bug 42138.

Comment 4

18 years ago
numbers are okay after 32 but they all have 0's after 50 now.  So, you'd expect 
51 but instead get 0!

Comment 5

18 years ago
sorry, I'm viewing this 50+ list item rendering problem with 6-18-m17 win98 
build.
Reassigning to buster
Assignee: clayton → buster

Comment 7

18 years ago
For what it's worth, the number 32 or 50 (or whatever) seems to be dependant on
the page being viewed. It goes up to 25 at the URL at http:
//discworld.imaginary.com:5678/boards.c?board=witchesguild

bug applies to Mac builds too, at least this one (2000-06-20-08-M17).

Comment 8

18 years ago
Bug 44958 seems to be a duplicate of this bug, but the numbering stops at 50
(for at least Linux and WinNT 4). 
*** Bug 44958 has been marked as a duplicate of this bug. ***
Nominating for nsbeta3 and adding relevant keywords.  This is pretty basic
stuff, and we shouldn't get it wrong.
Keywords: correctness, css1, html4, nsbeta3
(Assignee)

Comment 11

18 years ago
Taking. May be a dup of 44709, which I fixed yesterday.
Assignee: buster → waterson
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Assignee)

Comment 12

18 years ago
Yep, this was fixed with 44709.

*** This bug has been marked as a duplicate of 44709 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.