Closed Bug 429497 Opened 15 years ago Closed 15 years ago

Warning and error nsIInterfaceRequestor in the error console

Categories

(Calendar :: Provider: GData, defect)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: franjb68, Assigned: Fallen)

Details

(Whiteboard: [gdata-0.5])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: 

I'm having this problem with Thunderbird 2.0.0.12, Lightning 0.8 and GCalendar Provider 0.4.

Just after opening Thunderbird the error console shows the following warning:
Warning: nsIInterfaceRequestor requesting invalid interface
{a63f70c0-148b-11d3-9333-00104ba0fd40}

And the following error:

Error: [Exception... "'Component does not have requested interface' when
calling method: [nsIInterfaceRequestor::getInterface]"  nsresult: "0x80004002
(NS_NOINTERFACE)"  location: "<unknown>"  data: no]


Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
No warnings or errors
Thanks for reporting, patch coming soon.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Attached patch Add nsIPrompt β€” β€” Splinter Review
Since this change is trivial, I'm reviewing it myself. nsIPrompt is also used in a similar place in the caldav provider.


r=philipp
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #316269 - Flags: review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Severity: normal → trivial
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Whiteboard: [gdata-cvs]
Whiteboard: [gdata-cvs] → [gdata-0.5]
You need to log in before you can comment on or make changes to this bug.