Status

SeaMonkey
General
P3
normal
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: jmmrb, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
go to http://critique.net.nz/project/mozilla/general/principles/#metaphor
mozilla crashes:

please see also Talkback incidents : TB12602419Z,TB12602415X,TB12602412M

Tested in Build ID 2000061311 NT4

Comment 1

18 years ago
The page starts like this:

	<?xml version="1.0" encoding="UTF-8"?>
	<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" 	
	"DTD/xhtml1-strict.dtd">

Tested on PC/Linux.
Crashes on 2000061311 (M16 release) with a stack trace that starts with
#0  memcpy (dstpp=0x879e598, srcpp=0x0, len=3778)
#1  nsByteArrayInputStream::Read () from libxpcom.so
like many other "strict dtd not yet enabled" crashers, see bug 39520
and follow the trail of its dupes.

The same build does not crash if you set `ENABLE_STRICT' to `1' in your
environment before running mozilla.
Also it does not crash if you use recent M17 nightlies like 2000061420.
Marking worksforme.

Maybe this could be added to the M16 release notes (see also bug 42227):
	Mozilla M16 often crashes on XHTML pages served as text/html 
	(bug 39520). Setting `ENABLE_STRICT' to `1' in your environment 
	before running mozilla avoids these crashes. This is fixed in M17.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 2

17 years ago
**Mass Spamm**
adding verifyme keyword to all worksforme bugs.
Keywords: verifyme
(Reporter)

Comment 3

17 years ago
WorksForme!
joao
(Reporter)

Comment 4

17 years ago
WorksForme!
Build 2000092111 on NT4
joao

Comment 5

17 years ago
Verified on WinNT branch build 10/3.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Depends on: 433192

Updated

10 years ago
No longer depends on: 433192

Updated

9 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.