High CPU load while update confirmation window is open

RESOLVED DUPLICATE of bug 341749

Status

()

RESOLVED DUPLICATE of bug 341749
11 years ago
10 years ago

People

(Reporter: hgfriedmann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

When a new update arrives, a confirmation window appears that queries for a browser restart. When the browser is left unattended, CPU load goes high (with the update to 2.0.0.14 it used approximately 60-70% for some hours until user confirmation).

Reproducible: Always

Steps to Reproduce:
Wait for the next update ;-)
Actual Results:  
CPU load went high.

Expected Results:  
It shouldn't.

The same problem occures with Thunderbird.

Used addons:
CustomizeGoogle 0.7.1
FlashGot 0.9.5
NoScript 1.5.8
SessionManager 0.6.1.13

System:
Debian 4.0/ctvdr-distribution
VDR 1.4.7
Kernel 2.6.18-5-686
512 MB RAM
Celeron 2.0 GHz
Hauppauge Nexus 2.1 DVB-S
KNC-One TVStation DVB-S Plus

Comment 1

11 years ago
Was this an update from 2.0.0.13 or from an earlier version? Did you notice on earlier updates?
(Reporter)

Comment 2

11 years ago
It was an update from .13 to .14.
As far as I can remember, this problem occured on every single update. BTW, I use the tarred version, not the debian package; the same goes for Thunderbird.
(Reporter)

Comment 3

11 years ago
Some additional items I just realized:
-Before the last update I activated the setting to ask me before downloading new updates. Before that it was set to automatically download the update.
-So apparently the cpu-heating loop already occurs when firefox found a new update.
-If I'm not totally wrong, the same problem occured in branch 1.5.x. I just noticed when I wanted to specify the affected version.
Just my few thoughts...
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 4

10 years ago
Seeing this same issue on Thunderbird nightly (Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b3pre) Gecko/20090109 Shredder/3.0b2pre ID:20090109080257)
Not seeing this with on the Update Ready to Install page on Windows
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090110 Shiretoko/3.1b3pre

Comment 6

10 years ago
allso occurs on Win2k3 FFox 3.06, even after update window is closed
Saw this with a debug build tonight and it appears that the 3 progressmeters used in the wizard are causing this as stated in bug 341749. Duping this over to bug 341749.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 341749
You need to log in before you can comment on or make changes to this bug.