Applying rules for JavaScript, Cookies etc. for each website seperately (extensive black- and whitelisting)

RESOLVED DUPLICATE of bug 320522

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 320522
10 years ago
7 years ago

People

(Reporter: john, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.8 (like Gecko)
Build Identifier: 

Disabling "Accept cookies" but using the "Exceptions" whitelist extensively, one can set his preferences for cookie handling seperately for each website. Why not make this behavior explicit end extend it to other areas? I would love to have the possibility to define URLs and set my preferences for Java, JavaScript, Cookies, password remembering etc. seperately. That means, I would like to define black-/whitelists. For example, I would like to keep Java turned off globally (blacklisted for all websites), but use it for a handful of other websites which I know I can trust (whitelist), without having to change my settings manually every time I enter that site, und unset java everytime I leave it.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

8 years ago
Duplicate of Core bug 94035?

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 320522
You need to log in before you can comment on or make changes to this bug.