Closed Bug 429559 Opened 15 years ago Closed 15 years ago

Please use cache in Download Manager!

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 120809

People

(Reporter: Neo_In_Matrix, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041606 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041606 Minefield/3.0pre

I just reported bug #429558. This problem is essentially the same with that one. But since it's related to Download Manager, so I think it would be clearer to create a separate bug item.

Here it is.

When I right click a picture on a page and select 'Save Image As...', Download Manager is brought up to me - that's fine.

But a little annoyance is that it does not use the already downloaded file (already in cache). Instead, it tries to download from server again!

I am not quite sure what this design does good to me, but 100% of the time I DON'T want this behavior. What I want is just copied the image file from cache since I already spent time and bandwidth on this file.

If you don't get this, please imaging viewing many large pictures and you try to save them onto your local hard disk.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.