Last Comment Bug 429642 - Crash [@ nsAccessibleWrap::get_accKeyboardShortcut(tagVARIANT, unsigned short**) ]
: Crash [@ nsAccessibleWrap::get_accKeyboardShortcut(tagVARIANT, unsigned short...
Status: RESOLVED FIXED
: access, crash
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Windows XP
: -- critical (vote)
: mozilla7
Assigned To: Trevor Saunders (:tbsaunde)
:
: alexander :surkov
Mentors:
Depends on:
Blocks: fox3access
  Show dependency treegraph
 
Reported: 2008-04-18 04:00 PDT by Marco Zehe (:MarcoZ)
Modified: 2011-06-30 10:48 PDT (History)
6 users (show)
dsicore: blocking1.9-
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.60 KB, patch)
2011-06-25 00:14 PDT, Trevor Saunders (:tbsaunde)
surkov.alexander: review+
Details | Diff | Splinter Review
patch (1.61 KB, patch)
2011-06-28 16:02 PDT, Trevor Saunders (:tbsaunde)
no flags Details | Diff | Splinter Review

Comment 1 Damon Sicore (:damons) 2008-04-18 14:14:10 PDT
Again, not a significant number of crashes to block.  Marco, do we have any idea of how many beta testers are using accessibility?

Comment 2 Marco Zehe (:MarcoZ) 2008-04-24 22:42:48 PDT
(In reply to comment #1)
> Again, not a significant number of crashes to block.  Marco, do we have any
> idea of how many beta testers are using accessibility?

Unfortunately not. This one, along with some of the others, looks like someone was experimenting with calling our APIs and giving us wrong parameters, and we're not protecting properly against those cases. Alexander Surkov filed bug 429990 to deal with all these in one big sweep, but I am not sure we want to try and take this for 1.9 or wait until Firefox 3 ships.
Comment 3 David Bolter [:davidb] 2009-06-16 12:00:44 PDT
Mass un-assigning bugs assigned to Aaron.
Comment 4 David Bolter [:davidb] 2009-09-29 12:16:50 PDT
Is this bug stale?
Comment 7 Ted Mielczarek [:ted.mielczarek] 2011-03-11 07:11:33 PST
I get essentially the same stack from Visual C++, although the nsTArray frame is not there. Either the stack is corrupted, or some memory is corrupted and we're calling something we shouldn't be.
Comment 8 Trevor Saunders (:tbsaunde) 2011-06-25 00:14:25 PDT
Created attachment 541899 [details] [diff] [review]
patch

I think we want these checks any way and hopefully it'll fix the crashes.
Comment 9 alexander :surkov 2011-06-27 20:50:58 PDT
Comment on attachment 541899 [details] [diff] [review]
patch

Review of attachment 541899 [details] [diff] [review]:
-----------------------------------------------------------------

r=me since the patch makes sense

::: accessible/src/msaa/nsAccessibleWrap.cpp
@@ +494,5 @@
>  
> +  nsAutoString shortcut;
> +  nsresult rv = xpAccessible->GetKeyboardShortcut(shortcut);
> +  if (NS_FAILED(rv))
> +    return E_FAIL;

return GetHRESULT(rv);
Comment 10 Trevor Saunders (:tbsaunde) 2011-06-28 16:02:31 PDT
Created attachment 542645 [details] [diff] [review]
patch

fix return value
Comment 11 Trevor Saunders (:tbsaunde) 2011-06-30 10:39:22 PDT
landed http://hg.mozilla.org/mozilla-central/rev/1d351cc0e8c1

Note You need to log in before you can comment on or make changes to this bug.