Frequent hangs on page load (Adblock Plus? Javascript?)

VERIFIED DUPLICATE of bug 429903

Status

()

--
critical
VERIFIED DUPLICATE of bug 429903
11 years ago
9 years ago

People

(Reporter: ts.bugzilla, Unassigned)

Tracking

({hang, regression})

Trunk
x86
Windows XP
hang, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041606 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041606 Minefield/3.0pre

Firefox nightly builds (2008041606 and 2008041707) often hang on page load, e.g. pretty consistently when navigating on http://www.istartedsomething.com/ to the full post "Pictures of new and updated Surface Demo apps", as of now the 3rd post:
http://www.istartedsomething.com/20080418/pictures-of-new-and-updated-surface-demo-apps/#more-2878

As recommended in bug 418811, I attached windbg, and recorded a stack trace using "!analyze -v -hang" (not "hung" as mentioned in bug 418811).

The stack trace ends at js3250!JS_GetPrototype, so it seems to be different to bug 418811. I'll attach the log.

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Created attachment 316443 [details]
windbg log using "!analyze -v -hang"
(Reporter)

Comment 2

11 years ago
Created attachment 316472 [details]
another log, 20080418 nightly, fresh profile with adblock plus

On another machine I ran the same tests with a fresh profile, and the 2008041807 nightly.

The stack trace is similar, but not identical a bit further down...
The hang only occurred after I installed Adblock Plus.
(Reporter)

Updated

11 years ago
Summary: Frequent hangs on page load (Flash? Javascript?) → Frequent hangs on page load (Adblock Plus? Javascript?)
Regression range is
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1208216520&maxdate=1208223479
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
Keywords: hang

Updated

11 years ago
Flags: blocking1.9?

Updated

11 years ago
Severity: normal → critical
Eh, I should have duped to this, but everything is over in the other bug now.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429903

Updated

11 years ago
Flags: blocking1.9?
(Reporter)

Comment 5

11 years ago
seems to be gone
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008042604 Minefield/3.0pre ID:2008042604
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.