Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Empty findbar turns red and "Phrase not found" is displayed when "Highlight all" is enabled and search term is removed

VERIFIED FIXED in mozilla1.9.1b1

Status

()

Toolkit
Find Toolbar
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Pavlos Touboulidis, Assigned: graememcc)

Tracking

({regression})

Trunk
mozilla1.9.1b1
regression
Points:
---
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041807 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008041807 Minefield/3.0pre

Following the steps described below, the findbar incorrectly turns red and the "Phrase not found" is displayed while there's no phrase to search for (the findbar is empty).

Reproducible: Always

Steps to Reproduce:
1. Open any page that contains the letter 'a'
2. Hit Ctrl+F to open the Findbar, type 'a'
3. Click the highlight button so that it's on
4. Delete the letter 'a'
Actual Results:  
The findbar turned red

Expected Results:  
The findbar is empty so it should be white and the "Phrase not found" message not visible.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Empty findbar is red and "Phrase not found" is displayed → Empty findbar turns red and "Phrase not found" is displayed when "Highlight all" is enabled and search term is removed
Version: unspecified → Trunk
Regression range:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2005-12-16+13%3A00&maxdate=2005-12-16+23%3A00
Caused by Bug 313653, I think.
Blocks: 313653
Keywords: regression
Product: Firefox → Toolkit
(Assignee)

Comment 2

9 years ago
Created attachment 337864 [details] [diff] [review]
Patch v1
[Checkin: Comment 4]

The findbar highlighting code shouldn't attempt to search for empty strings.
Assignee: nobody → graememcc_firefox
Status: NEW → ASSIGNED
Attachment #337864 - Flags: review?(mano)
Comment on attachment 337864 [details] [diff] [review]
Patch v1
[Checkin: Comment 4]

r=mano
Attachment #337864 - Flags: review?(mano) → review+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Comment on attachment 337864 [details] [diff] [review]
Patch v1
[Checkin: Comment 4]

http://hg.mozilla.org/mozilla-central/rev/2321c54b2a8a
Attachment #337864 - Attachment description: Patch v1 → Patch v1 [Checkin: Comment 4]
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b1
Verified with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080927020752 Minefield/3.1b1pre ID:20080927020752

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080927033433 Minefield/3.1b1pre ID:20080927033433
Status: RESOLVED → VERIFIED
Flags: in-litmus?
(Assignee)

Comment 6

9 years ago
Created attachment 343247 [details] [diff] [review]
Test v1 (checked in)

Patch to test for this.

(Note I've used the opportunity to do some trivial code cleanup that is too trivial to justify it's own bug: it reorders the tests in the makefile into bug# order, corrects my incorrect licence headers and removes a spurious comment from bug 451286's test).
Attachment #343247 - Flags: review?(mano)
nominating for intestsuite based on Comment 6
Flags: in-testsuite?
Comment on attachment 343247 [details] [diff] [review]
Test v1 (checked in)

r=mano
Attachment #343247 - Flags: review?(mano) → review+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Whiteboard: test requires checkin

Updated

9 years ago
Attachment #343247 - Attachment description: Test v1 → Test v1 (checked in)
Comment on attachment 343247 [details] [diff] [review]
Test v1 (checked in)

http://hg.mozilla.org/mozilla-central/rev/23a15042356f

Updated

9 years ago
Flags: in-testsuite? → in-testsuite+
Keywords: checkin-needed
Whiteboard: test requires checkin
With the automated test we should be fine.
Flags: in-litmus? → in-litmus-

Updated

8 years ago
Depends on: 493658

Updated

8 years ago
No longer depends on: 493658
You need to log in before you can comment on or make changes to this bug.