Closed Bug 429752 Opened 12 years ago Closed 11 years ago

Crash upon page load [XError: 'BadAlloc (insufficient resources for operation)']

Categories

(Firefox :: General, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 424333

People

(Reporter: quidam, Unassigned)

References

()

Details

(Keywords: crash)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008041123 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008041123 Firefox/3.0b5

Once the page http://gameex.net loads and starts to render, Firefox simply crashes.

Reproducible: Always

Steps to Reproduce:
1. Navigate to http://gameex.net
2. Observe random crash
Actual Results:  
Firefox instantly crashes without warning.

Expected Results:  
It should load the page without crashing.

Default theme. OS: Arch Linux x86_64: firefox3-branded package (http://aur.archlinux.org/packages.php?ID=15911).
Please attach a human readable stacktrace.

wfm with Mozilla/5.0 (Windows; U; Windows NT 6.0; rv:1.9pre) Gecko/2008041819 SeaMonkey/2.0a1pre
Attached file Terminal Output
I can confirm this with a recent Linux trunk build.
The page uses a 8 x 50096 px table background image (http://www.gameex.net/Portals/_default/Skins/back0000.jpg).
Firefox 2 does not crash, because "The image “...” cannot be displayed, because it contains errors."
This is probably a dupe of bug 166862.
Or bug 424333.  I've made test builds available:
https://build.mozilla.org/tryserver-builds/2008-04-20_18:00-mpalmgren@mozilla.com-424333_patch2b/
Depends on: 424333
Keywords: crash
Summary: Crash upon page load → Crash upon page load [XError: 'BadAlloc (insufficient resources for operation)']
Latest Shiretoko does not die and gets draw errors instead.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
No longer depends on: 424333
Resolution: --- → DUPLICATE
Duplicate of bug: 424333
You need to log in before you can comment on or make changes to this bug.