Closed Bug 429796 Opened 12 years ago Closed 12 years ago

No longer exposing document title on "internal frame", which is the parent of the document accessible, effective April 16.

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
major

Tracking

()

RESOLVED WONTFIX
mozilla1.9

People

(Reporter: MarcoZ, Assigned: aaronlev)

References

Details

(Keywords: access, regression)

Regression from fix for bug 428954.

With the April 15 build, the hierarchy excerpt looks like this:

propertypage xul:notificationbox
- internal frame heise online - 7-Tage-News xul:browser
- - document heise online - 7-Tage-News 

Since April 16, it looks like this:
propertypage xul:notificationbox
- internal frame xul:browser
- - document heise online - 7-Tage-News 

Jamie told me this yesterday that NVDA relies on the document title being the accessible name for the frame.
It has been done intentionally (some details in bug 428954 comment #7). Though let's Aaron resolve the bug.
We never should have exposed the same name twice in the hierarchy:
- The redundancy could lead some ATs to speak it twice
- Copy to clipboard commands could end up copying the same text twice.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.