Closed Bug 430051 Opened 12 years ago Closed 12 years ago

Event edit dialog won't save category update

Categories

(Calendar :: Provider: GData, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: klint, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9pre) Gecko/2008042006 Minefield/3.0pre
Build Identifier: TB 2.0.0.12 + Lightning 20080420

When editing or creating an event, I'm not able to set a category!

Reproducible: Always

Steps to Reproduce:
1.Create or edit a new event
2.Select a category in the drop down list
3.Save the event
Actual Results:  
The category is not changed

Expected Results:  
The category should change from None to the chosen one.

No error message in the console
@klint: I checked this issue at windows and linux with the same build and it works for me. Which kind of calendar do you use? Is the chosen category one from the default list or a self created?
Do you save your events to Google Calendar server? Google Calendar doesn't support categories as far as I know.
Yes I did it for Google Calendars. And I confirm that it works for local calendars.
Sorry and thanks for the answer :)
http://wiki.mozilla.org/Calendar:GDATA_Provider#I_have_set_a_category.2C_but_it_does_not_show.21

Q: I have set a category, but it does not show!
A: Google's API does not support setting event categories, 
   so there is no easy way to implement this for the Provider.

Based on the FAQ entry cited above this bug might be resolved INVALID. Philipp, what do you say? Or should the Categories dropdown be disabled when an event is created/edited in Google Calendar?
Component: Lightning Only → Provider: GData
QA Contact: lightning → gdata-provider
I'd also say so, a separate bug should be filed to add capabilities for categories.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.