"Error: this.keyManager_ is null" clearing cookies when safebrowsing is disabled

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
4 years ago

People

(Reporter: bugzilla.i.sekler, Unassigned)

Tracking

3.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008042112 Firefox/3.0pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008042112 Firefox/3.0pre

Error Console:

Error: this.keyManager_ is null
Source File: file:///***/firefox/components/nsUrlClassifierListManager.js
Line: 506

clearing cookies if both browser.safebrowsing.enabled and browser.safebrowsing.malware.enabled are set to false. It points actually to http://lxr.mozilla.org/seamonkey/source/toolkit/components/url-classifier/content/listmanager.js#536

First seen on 2008-02-28. Happens on Windows as well -> All. Bug 360387??


Reproducible: Always

Steps to Reproduce:
1. Uncheck "Tell me if the site I'm visiting is a suspected attack site" and "Tell me if the site I'm visiting is a suspected forgery" options, restart Firefox.
2. Browse around
3. Clear all cookies ("Show Cookies..." -> "Remove all Cookies", for example)

Actual Results:  
Getting "Error: this.keyManager_ is null" in the Error Console.

Expected Results:  
No error.


The choice of the product and the component is obviously wrong, please move the bug to a better one (toolkit something?) if possible.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
Verified on latest trunk (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9pre) Gecko/2008050804 Minefield/3.0pre)

Comment 2

10 years ago
Fx3rc2build2 on Vista, confirmed, I see the same error in the Error Console.
Status: UNCONFIRMED → NEW
Component: General → Phishing Protection
Ever confirmed: true
Version: Trunk → 3.0 Branch
QA Contact: general → phishing.protection
Is this still an issue with the current code?
Status: NEW → UNCONFIRMED
Ever confirmed: false
(Reporter)

Comment 4

6 years ago
(In reply to Justin Dolske [:Dolske] from comment #3)

> Is this still an issue with the current code?

No, the error has gone, probably already a very long time ago.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 5

5 years ago
This bug started for me since FF 25 and still exists in FF 26: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0

Starting FireFox with "Block reported attack sites" & "Block reported web forgeries" disabled, will output the error when clearing the cookies via settings or by calling Components.interfaces.nsICookieManager -> removeAll() in an addon.

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "this.keyManager_ is null" {file: "resource://gre/components/nsUrlClassifierListManager.js" line: 515}]' when calling method: [nsIObserver::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://browser/content/preferences/cookies.js :: <TOP_LEVEL> :: line 713"  data: yes]
************************************************************
(Reporter)

Comment 6

5 years ago
(In reply to Edan from comment #5)

> This bug started for me since FF 25 and still exists in FF 26: Mozilla/5.0
> (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
> [...]

I can confirm that this regressed in Fx 25.0, but WFM again with the current m-c trunk.
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.