Closed Bug 430091 (gdk_x_error) Opened 15 years ago Closed 14 years ago

gdk_x_error, regular crashes, not reproducible (with stacks)

Categories

(Core :: Widget: Gtk, defect)

1.8 Branch
x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 458092

People

(Reporter: KaiE, Unassigned)

Details

(Keywords: crash)

Attachments

(3 files)

For quite a while I've been regularly crashing with Seamonkey 1.1.x with an error message on the console like this:
Gdk-ERROR **: The program 'gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadIDChoice (invalid resource ID chosen for this connection)'.
  (Details: serial 44446466 error_code 14 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...

Luckily Fedora now allows me to run the same optimized build with full debug information installed, so I've recently started to do what's been suggested in that error message.

In the meantime I've collected 3 stacks, will attach them.
Attached file stack 1
Attached file stack 2
Attached file stack 3
Alias: gdk_x_error
Severity: normal → critical
Component: Embedding: GTK Widget → Widget: Gtk
Keywords: crash
QA Contact: gtk-widget → gtk
I have been getting this type of abort fairly regularly on Ubuntu,
currently at:
Linux terrypc 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686 GNU/Linux

I used the "--sync" suggestion (but without debug info), and here's the 
brief backtrace:
The program 'firefox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadIDChoice (invalid resource ID chosen for this connection)'.
  (Details: serial -1135830161 error_code 14 request_code 157 minor_code 4)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7f34767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb7f3481e]
#2 /usr/lib/libX11.so.6 [0xb6a8e518]
#3 /usr/lib/libX11.so.6(XFreeCursor+0x25) [0xb6a6a8f5]
#4 /usr/lib/libqt-mt.so.3(_ZN11QCursorDataD1Ev+0x3f) [0xb4ea5389]
#5 /usr/lib/libqt-mt.so.3(_ZN7QCursorD1Ev+0x5a) [0xb4ea558e]
#6 /usr/lib/libqt-mt.so.3 [0xb4ea55d5]
#7 /lib/tls/i686/cmov/libc.so.6(exit+0xd4) [0xb7cd2084]
#8 /usr/lib/libgdk-x11-2.0.so.0 [0xb6674637]
#9 /usr/lib/libbonoboui-2.so.0 [0xb628c665]
#10 /usr/lib/libX11.so.6(_XError+0xfe) [0xb6a8773e]
#11 /usr/lib/libX11.so.6 [0xb6a8ee5c]
#12 /usr/lib/libX11.so.6(_XReply+0x15a) [0xb6a8f21a]
#13 /usr/lib/libX11.so.6(XSync+0x6a) [0xb6a8324a]
#14 /usr/lib/libX11.so.6 [0xb6a833c5]
#15 /usr/lib/libX11.so.6 [0xb6a8f57d]
#16 /usr/lib/libXrender.so.1(XRenderCreatePicture+0xb5) [0xb6b3a9d5]
#17 /usr/lib/libcairo.so.2 [0xb6d748a8]
#18 /usr/lib/libcairo.so.2 [0xb6d760c5]
#19 /usr/lib/libcairo.so.2 [0xb6d49679]


Any hope for a fix to this, soon?
                                                                     
I get this message too.  I'm using Fedora 9 on x86_64.  I've had this problem for some time with many versions of firefox.  The one I'm currently using is firefox-3.0.4-1.fc9.x86_64.

I try to gdb, but I encounter GDB error messages.  I've reported them to the GDB list but have gotten no response.
Thanks for the report.  I'll mark this as a dupe of bug 458092, to direct any further info to one place.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458092
You need to log in before you can comment on or make changes to this bug.