Closed Bug 430185 Opened 12 years ago Closed 11 years ago

Can't add event via email invitation to remote calendars

Categories

(Calendar :: Provider: GData, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 456865

People

(Reporter: j.gilbert, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Thunderbird 2.0.0.12, Lightning 0.8

Hi,

I'm using Thunderbird and Lightning with Provider GData and GCALDaemon to access Google Calendar.

I'm having a slight variation on bug - 401720.

I have multiple calendars 5 local and one remote.

Using Provider Gdata:

When I try to accept an invitation I am prompted with the 'Select Calendar' dialog, all my calendars are listed, if I add to the remote calendar (with GData) it seems to add it, no error, but doesn't actually add it to the calendar.

GCALDaemon: (The reason I tried GCALDaemon was because it allows sending of invitations via email which Provider doesn't)

When I try to accept an invitation I am prompted with the 'Select Calendar' dialog, all my calendars are listed but I can only add the event to my local calendars (or the remote calendar via GData) I am not able to select the remote calendar (with GCALDaemon) in the list.

If I add the event to a local calendar, I can then go into my calendar, edit event and change the calendar to the remote calendar, either GData or GCALDaemon.

Any assistance would be greatly appreciated.

Reproducible: Always

Steps to Reproduce:
1.Add remote calendar with GData and GCALDaemon
2.Accept Invitation
3.Attept to select remote calendar from select calendar dialog
Actual Results:  
Same as in details

Expected Results:  
Allowed me to add an event to my remote calendar
Do you see any error message when performing the steps? Please check Tools -> Error Console and copy+paste them.
Hi Stefan,

Thanks for the prompt reply.

I am now able to accept -> add to the remote GCALDaemon calendar fine, not sure why it's now suddenly working after not working yesterday or this morning.

The GData still lets me add it just doesn't add it to the calendar and nope, no error in the error console. 
In case you are using a nightly, I just fixed a bug regarding invitations. More to follow. I think your bug is covered in the other bugs I'm working on.
Thanks Philipp, Not using a nightly but look forward to your bug fixes ;-)
So this failure is only specific to the Provider for Google Calendar extension?

Have you enabled or disabled the experimental offline cache for this calendar? 
Yes only for the Provider.

I have not enabled or disabled the experimental offline cache.
Component: Lightning Only → Provider: GData
QA Contact: lightning → gdata-provider
No longer blocks: 436056
Jane, please test this in a recent nightly, while accepting invitations onto a google calendar isn't really something I'd suggest unless you received the invitation for your google account specifically, in which case the item should already be in your calendar (needs a google UI option to enable).
Hi Phillip, I tried the nightly but it said that the Lightning add-on was incompatible.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456865
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.