Last Comment Bug 430274 - xpidl should be statically linked
: xpidl should be statically linked
Status: RESOLVED WONTFIX
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Gregory Szorc [:gps]
Mentors:
: 436901 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 07:33 PDT by Dave Townsend [:mossop]
Modified: 2012-03-11 05:23 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Dave Townsend [:mossop] 2008-04-22 07:33:00 PDT
Since xpidl is shipped with the sdk it should be statically linked to avoid depending on specific versions of libraries being available on the users machine. 

Currently the mac version for instance relies on libintl.3.dylib being present since that is what is there on the mac reference platform. However it appears to be impossible to compile this version on leopard. It is possible to symlink to victory but it'd be better to just avoid this.
Comment 1 Dave Townsend [:mossop] 2008-05-15 03:09:48 PDT
Apparently this isn't possible since the appropriate versions of all the libraries aren't available generally :(
Comment 2 Atul Varma [:atul] 2008-06-02 15:41:34 PDT
*** Bug 436901 has been marked as a duplicate of this bug. ***
Comment 3 Atul Varma [:atul] 2008-06-02 15:43:35 PDT
I've added documentation providing workarounds for this bug on MDC:

http://developer.mozilla.org/en/docs/Gecko_SDK#Issues_with_the_OS_X_SDK

Note You need to log in before you can comment on or make changes to this bug.