Closed Bug 430371 Opened 15 years ago Closed 15 years ago

Restore borders to the toolbars for Vista Classic

Categories

(Firefox :: Theme, defect)

x86
Windows Vista
defect
Not set
minor

Tracking

()

VERIFIED FIXED
Firefox 3

People

(Reporter: kliu, Assigned: kliu)

References

Details

(Keywords: polish, regression)

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042207 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042207 Minefield/3.0pre

Bug 420236 removed toolbar borders from the Vista theme.  While this looks fine in the default Vista theme, it does not look very good in Classic, especially since the Classic toolbox lacks a bottom border to separate the toolbars from the content.

Reproducible: Always

Steps to Reproduce:
N/A
Blocks: 430366
Keywords: polish, regression
Version: unspecified → Trunk
Attached image current appearance
Notice the lack of any border between the toolbox and the start of the content area, giving the appearance an incomplete look.
Attachment #317140 - Attachment description: trivial patch → trivial patch make Vista Classic look the same as XP/2K Classic
Attachment #317140 - Flags: ui-review?(beltzner)
Attachment #317140 - Flags: review?(gavin.sharp)
Attachment #317140 - Flags: review?(gavin.sharp) → review+
Can you attach an "after" screenshot?
Assignee: nobody → kliu.bugzilla.3c9f
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Also: I granted you canconfirm/editbugs, so you can edit and file bugs as NEW now.)
Attached image restored borders
Restored borders: this should look the same as 2K/XP Classic (except for the different icons, of course)

(Gavin: Thanks!)
Status: NEW → ASSIGNED
Attachment #317140 - Flags: ui-review?(beltzner)
Attachment #317140 - Flags: ui-review+
Attachment #317140 - Flags: approval1.9+
mozilla/browser/themes/winstripe/browser/browser-aero.css 	1.6 
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
verified fixed using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008042407 Minefield/3.0pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.