Last Comment Bug 430445 - scroll position on boxes can be negative
: scroll position on boxes can be negative
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 364612 111034
  Show dependency treegraph
 
Reported: 2008-04-23 04:44 PDT by Neil Deakin
Modified: 2012-08-20 09:53 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (643 bytes, application/vnd.mozilla.xul+xml)
2008-04-23 04:44 PDT, Neil Deakin
no flags Details

Description Neil Deakin 2008-04-23 04:44:31 PDT
Created attachment 317249 [details]
testcase

This test shows that the top/left scroll position can be 0, due to the overflow from the native widget theme. This is being applied on Mac to buttons/textboxes/etc, so this bug is easier to reproduce on Mac. (Windows only has overflow for dropmarkers, and Linux only for tabs) It involves several characteristics:

- nsNativeTheme:GetWidgetOverflow returns a size
- The scroll position starts at 0,0 but it can be moved lower to -4,-4 using the scrollBy method.
- The 0 margin on the textbox in the testcase seems to be needed as well
Comment 1 Neil Deakin 2012-08-20 09:53:21 PDT
This looks to be fixed.

Note You need to log in before you can comment on or make changes to this bug.