Crash [@ nsPropertyTable::PropertyList::Equals] with -moz-column, position:fixed

VERIFIED FIXED in mozilla1.9.2a1

Status

()

Core
Layout
--
critical
VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: dholbert)

Tracking

(Blocks: 1 bug, 5 keywords)

Trunk
mozilla1.9.2a1
assertion, crash, testcase, verified1.9.0.14, verified1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.1 +
blocking1.9.0.14 +
wanted1.9.0.x +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:critical?][fixed by bug 363247], crash signature)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
Created attachment 317414 [details]
testcase (crashes Firefox when closed)

Loading the testcase triggers:

###!!! ASSERTION: reflow roots should never split: 'status == NS_FRAME_COMPLETE', file /Users/jruderman/trunk/mozilla/layout/base/nsPresShell.cpp, line 6296

Closing the window triggers:

Crash [@ nsPropertyTable::PropertyList::Equals] dereferencing 0xddddde09.

Related to bug 399994?
(Reporter)

Updated

9 years ago
Whiteboard: [sg:critical?]
(Reporter)

Updated

9 years ago
Flags: blocking1.9.1?
Flags: blocking1.9.1? → wanted1.9.1+
(Assignee)

Comment 1

9 years ago
Crashes for me using yesterday's linux nightly, when I close the testcase's tab.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081028 Minefield/3.1b2pre

 OS --> All;  Assignee --> me
Assignee: nobody → dholbert
OS: Mac OS X → All
(Assignee)

Updated

9 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

9 years ago
Crash report:
http://crash-stats.mozilla.com/report/index/d10bcefa-a5fc-11dd-99d6-001cc4e2bf68
(Assignee)

Comment 3

9 years ago
Created attachment 345372 [details]
testcase 2 (crashes Firefox when closed)

This testcase is tweaked a bit.
 - uses <br> instead of  newline+"whitespace: pre" to trigger a break
 - uses -moz-column-count:1 instead of -moz-column-width to trigger moz-col usage
 - Adds backgrounds & a border to show what's going on
 - Improved readability of style attribute, using newlines.
Like the previous one, this testcase crashes when I close or reload the tab.
(Assignee)

Comment 4

9 years ago
FWIW, I also still get the assertion mentioned in comment 0, using both testcases.

###!!! ASSERTION: reflow roots should never split: 'status == NS_FRAME_COMPLETE', file /mozilla/layout/base/nsPresShell.cpp, line 6338
(Assignee)

Comment 5

9 years ago
Created attachment 345746 [details]
backtrace of crash on testcase 2

Here's a backtrace of the crash triggered by testcase 2.

A few annotations:
 - At stack level 8, aPropertyName is the atom for "ExcessOverflowContainersProperty".
 - At stack levels 2-3, aPropertyName is the atom for "OverflowProperty". (This is passed in from level 4, which is GetOverflowFrames())

Basically, it looks like we're crashing because we're partway through deleting all the propertyLists in the propertyTable (stack level 12), and then we try to iterate across those same propertyLists and call methods on them ("Equals" in this case) (at stack level 1).
Shouldn't we be deleting frame properties when the frame is destroyed?  Or do we suppress that during pres shell destruction?
We do, yes.
(In reply to comment #0)
> ###!!! ASSERTION: reflow roots should never split: 'status ==
> NS_FRAME_COMPLETE', file
> /Users/jruderman/trunk/mozilla/layout/base/nsPresShell.cpp, line 6296

I think this assertion is the same problem described in bug 468771 comment 8.  Not sure if the crash is, though, although it seems likely.
Depends on: 468771
(Assignee)

Comment 9

9 years ago
Both testcase are now WFM in my mozilla-central debug build and nightly build.

("WFM" = No crash & no assertions at load, reload, or tab-closing)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090209 Minefield/3.2a1pre

My debug build is at changeset 5f349409c9d5 (up-to-date as of this morning).
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 10

9 years ago
This isn't yet fixed in 191, though.  I just tested today's 191 nightly, and I got a crash:
http://crash-stats.mozilla.com/report/pending/7a08dbdb-a62f-44dd-9372-b43e12090209
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090209 Shiretoko/3.1b3pre
Whiteboard: [sg:critical?] → [sg:critical?][needs 1.9.1 fix]
(Assignee)

Comment 11

9 years ago
Fix range for mozilla-central:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090204 Minefield/3.2a1pre
Built from http://hg.mozilla.org/mozilla-central/rev/4ada519b5c97

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090205 Minefield/3.2a1pre
Built from http://hg.mozilla.org/mozilla-central/rev/5de9f1e51c68

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4ada519b5c97&tochange=5de9f1e51c68
Maybe bug 363247?
Bug 399994 is still crashing.
Yes, confirmed by local backout that it was fixed by bug 363247.
Depends on: 363247
(Assignee)

Comment 15

9 years ago
Great, thanks dbaron!  And it looks like you've already requested approval1.9.1 on that bug's patch, so hopefully it'll be approved and able to land there soon.
Whiteboard: [sg:critical?][needs 1.9.1 fix] → [sg:critical?]
I landed bug 363247 on 1.9.1, so marking this fixed1.9.1.
Keywords: fixed1.9.1
Verified fixed on OS X and Windows with:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090310 Minefield/3.2a1pre ID:20090310044308

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090309 Shiretoko/3.1b4pre (.NET CLR 3.5.30729) ID:20090309034003
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1, testcase → testcase-wanted, verified1.9.1
Hardware: x86 → All
Resolution: WORKSFORME → FIXED
Whiteboard: [sg:critical?] → [sg:critical?][fixed by bug 363247]
Target Milestone: --- → mozilla1.9.2a1
Flags: wanted1.9.0.x+
Flags: blocking1.9.0.13?
Keywords: testcase-wanted → testcase
Flags: blocking1.9.0.13? → blocking1.9.0.13+
So this is blocking1.9.0.14+, but I can't reproduce it on my 1.9.0 build.  Can anybody else?
dbaron: I can reproduce this using testcase 2 with Firefox 3.0.13 on Mac.

I get bp-082f9466-f9f5-4f9e-a608-a88b02090809.
I can't even get the testcase to emit a valgrind warning with DEBUG_TRACEMALLOC_FRAMEARENA.  (And no assertion, either.)
Might be opt only? I definitely see it.
Keywords: fixed1.9.0.14
Verified fixed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.14pre) Gecko/2009081305 GranParadiso/3.0.14pre (.NET CLR 3.5.30729) for 1.9.0.14. I saw the crashes with the test cases here in 1.9.0.13.
Keywords: fixed1.9.0.14 → verified1.9.0.14
Group: core-security
(Reporter)

Comment 23

8 years ago
Crashtest: Crashtest: http://hg.mozilla.org/mozilla-central/rev/4da43cad0331
Flags: in-testsuite+
Crash Signature: [@ nsPropertyTable::PropertyList::Equals]
You need to log in before you can comment on or make changes to this bug.