The default bug view has changed. See this FAQ.

[RFE] Permit to change the default free/busy attribute policy for all-day events

VERIFIED FIXED in 0.9

Status

Calendar
Preferences
--
enhancement
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Laurent Bauvens, Assigned: dbo)

Tracking

unspecified

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.13pre) Gecko/20080331 Sunbird/0.8

All-day events are marked by default with a 'free' attribute. To change this attribute, you must go into the menu 'Options' > 'Show Time As' and choose 'Busy'.

It would be nice to give to the user the possibility of changing the default all-day free/busy policy with the creation of a new preference key.

Reproducible: Always

Steps to Reproduce:
1.Create a new all-day event
2.Go to menu Options > Show Time As
Actual Results:  
Event is marked as 'Free'

Expected Results:  
Event is marked as 'Busy'
(Assignee)

Comment 1

9 years ago
Created attachment 319537 [details] [diff] [review]
patch

I think this enhancement makes sense; drive-by patch reading default from pref.
Assignee: nobody → daniel.boelzle
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #319537 - Flags: review?(philipp)

Comment 2

9 years ago
I don't think users should mess with strings like "TRANSPARENT" or "OPAQUE" via advanced preferences especially because comments are not visible in the UI. Setting it to e.g. "foobar" would mean invalid .ics is produced. In my opinion we should use just a boolean preference e.g. calendar.default.allday.showAsBusy with true/false. Mapping to "TRANSPARENT" or "OPAQUE" is done internally.

Comment 3

9 years ago
Maybe the default value for non all day events could be moved to preferences in the same step too.
(Assignee)

Comment 4

9 years ago
This is an expert's setting, I think it's OK to use those values.
Comment on attachment 319537 [details] [diff] [review]
patch


> function setShowTimeAs(allDay) {
>-    gShowTimeAs = allDay ? "TRANSPARENT" : "OPAQUE";
>+    gShowTimeAs = allDay ? getPrefSafe("calendar.allday.defaultTransparency", "TRANSPARENT") : "OPAQUE";
>     updateShowTimeAs();
> }
For bonus points, add () around the whole ?: condition.

r=philipp in any case
Attachment #319537 - Flags: review?(philipp) → review+
If there are no other values other than transparent and opaque, I think its not a bad idea to make it boolean, since even as an expert you don't have to mess with specific string values.
(Reporter)

Comment 7

9 years ago
Wooh! This is the speediest patch action for a proposal I've ever seen ! :)

Thank you very much
(Assignee)

Comment 8

9 years ago
I think there are good reasons why the RFC inventors have chosen terms instead of just a boolean value for that property. It makes the meaning more readable (instead of encoding it into the property's name) and leaves it open for future values.
(Assignee)

Comment 9

9 years ago
(In reply to comment #3)
> Maybe the default value for non all day events could be moved to preferences in
> the same step too.

IMO this depends on whether there's really a use case for that (which I doubt).
(Assignee)

Comment 10

9 years ago
Anyway, we could file a follow-up RFE if someone shows interest.

Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9

Comment 11

9 years ago
Checked in lightning build 2008062503 and Sunbird 20080624 -> VERIFIED.
Status: RESOLVED → VERIFIED

Comment 12

9 years ago
I think this patch really enhances Lightning! Good job! 

Is it planned to include this in the "not advanced" options? Because I still think that many users don't understand why their all-day events are not marked a busy.
You need to log in before you can comment on or make changes to this bug.