Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Microsoft's Silverlight plug-in is installed but it doesn't do anything.

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
--
minor
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Dustin Kane, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

On the Mozilla Firefox 3 Beta, I installed Microsoft's Silverlight plug-in and when i press Tools - Add-ons - Plugins and i find Silverlight, it appears to be installed and working. However, whenever I am on Microsoft.com it asks me if i want to install Silverlight. I say ok and in the middle of installing it says there was an error. I assume the error was that it was already installed. Also, the things that require Silverlight don't work but they do on Firefox 2.

Reproducible: Always

Steps to Reproduce:
1.Go to Microsoft.com
2.Install Silverlight
3.Go back to Microsoft.com
Actual Results:  
It appeared that installing Silverlight had no effect

Expected Results:  
It should have made animations on the website visible and it shouldn't have asked me to install it once again.
(Reporter)

Comment 1

9 years ago
Firefox 3 beta 5

Comment 2

9 years ago
Firefox 3.0 Beta 3 changed some issues with handling <object>. Silverlight 2 beta 2 will be the first Firefox 3-compatible build.

Comment 3

9 years ago
dup of bug 385720?

Comment 4

9 years ago
I know this isn't a tech support forum but I would suggest trying this to see if the problem lies with Silverlight itself and not Firefox. I had the same problem except mine was IE7.

-----------------------------------------------------------------------------


HKEY_CLASSES_ROOT\AgControl.AgControl does not have READ access fix


1. Run regedit (start->run->regedit)
2. Navigate to HKEY_CLASSES_ROOT\AgControl.AgControl (if you get a message that says "AgControl.AgControl cannot be opened. An error is preventing this key from being opened. Details: Access is denied." proceed to the "Taking ownership of the key" section)
3. Right click and choose "Permissions"
4. Click "Add"
5. Either add your windows username or your network username in the the "Enter the object names to select" and click "Check Names". Your name should take the proper format. If it does not try clicking "Advanced" and searching for your username. My windows username was the one I used.
6. Click OK
7. Select your new username in the top pane and in the lower pane (Permissions for <username>) check the Allow box next to Read.
8. Click OK

Check Silverlight installation in IE by going to http://www.silverlight.net/



Taking ownership of the key (If you're getting access denied errors while trying to set permissions)


You can download the following tool from microsoft to open an
instance of regedit as system:

http://www.microsoft.com/technet/sysinternals/utilities/psexec.mspx

The following command line will open a "system" regedit:

psexec -s -i regedit

(Note: You have to execute this command line from an "administrator" command
prompt [right-click command prompt and click run as administrator])

Return to step 3 above 

Comment 5

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

I am experiencing the same problem.  However, this is with Firefox 3.0 Release, and Silverlight 2 Beta 2.  I see this has not been updated since May (pre-Firefox 3 Release)

Comment 6

9 years ago
Dan is it it certain sites or all sites that you experience this with?

Some sites use old Silverlight.js javascript to do browser detection so they won't recognize Firefox 3 and you'll get a "Download Silverlight" page.

Comment 7

9 years ago
It is only certain websites.  But about half of www.microsoft.com does it which is why I brought it up, I would figure they wouldn't use an old version.  But they may, there's Microsoft for ya :)

Comment 8

9 years ago
Microsoft is just like any large company: completely decentralized. Outside companies put together god knows how much of their site (I've done a few) and once they get launched they don't get revisited when something breaks. Chances are good that no one's even aware that they don't work.

You'll need to provide an example of one that works and one that doesn't work if you want somebody to look into the issue.

Comment 9

9 years ago
I was going through my bug vote list and noticed that this bug seems to have been fixed using Firefox 3.0.4 and the official release of Silverlight (version 2.0.31005.0) on my Mac (OS X 10.5.5).

I can go to Microsoft.com/downloads and choosing to use the beta site that incorporates Silverlight works. I can also go to the main Microsoft.com site and it uses the Silverlight plugin now.

Comment 10

9 years ago
yup wfm now.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.