Crash while pressing the back button

VERIFIED WONTFIX

Status

MozillaClassic
P3
major
VERIFIED WONTFIX
20 years ago
19 years ago

People

(Reporter: Patrick Scieller, Assigned: rickg)

Tracking

other
x86
Windows NT

Details

(Reporter)

Description

20 years ago
Created by Patrick Scieller (scieller@bigfoot.com) on Tuesday, June 9, 1998 7:26:31 AM PDT
Additional Details :
Mozilla failed as I was pushing the [Back] button on the
toolbar.
A personal bookmark folder was opened on the left.
Previously navigation went to Altavista, Lycos and Yahoo and
I closed and
opened left bookmark folders two or three times.

******** DEBUGGER INFORMATION *********
call stack
----------
lo_UpdateStateWhileFlushingLine(MWContext_ * 0x0099cb00,
lo_DocState_struct * 0x01c22958) line 7498 + 9 bytes
lo_FlushLineList(MWContext_ * 0x0099cb00, lo_DocState_struct
* 0x01c22958, unsigned long 0, unsigned long 0, int 0) line
1083 + 13 bytes
lo_EndLayer(MWContext_ * 0x0099cb00, lo_DocState_struct *
0x01c22958, int 1) line 2230 + 19 bytes
lo_FinishLayout(MWContext_ * 0x0099cb00, lo_DocState_struct
* 0x01c22958, long 524288) line 3676 + 15 bytes
lo_FlushBlockage(MWContext_ * 0x0099cb00, lo_DocState_struct
* 0x01c22958, lo_DocState_struct * 0x01c22958) line 2747 +
18 bytes
lo_block_src_exit_fn(URL_Struct_ * 0x00c3cb10, int 1,
MWContext_ * 0x0099cb00) line 471 + 17 bytes
net_CallExitRoutine(void (URL_Struct_ *, int, MWContext_ *)*
0x004a8cb0 lo_block_src_exit_fn(URL_Struct_ *, int,
MWContext_ *), URL_Struct_ * 0x00c3cb10, int 1, int 23,
MWContext_ * 0x0099cb00) line 1053 + 15 bytes
NET_ProcessNet(PRFileDesc * 0x00000000, int 1) line 3309 +
39 bytes
net_process_slow_net_timer_callback(void * 0x00000000) line
216 + 9 bytes
wfe_ProcessTimeouts(unsigned long 11872822) line 298 + 12
bytes
FireTimeout(HWND__ * 0x001000ce, unsigned int 275, unsigned
int 777, unsigned long 11872822) line 60 + 9 bytes
USER32! 77e71373()
CNetscapeApp::Run() line 1608 + 8 bytes
AfxWinMain(HINSTANCE__ * 0x00400000, HINSTANCE__ *
0x00000000, char * 0x00141fea, int 1) line 52 + 11 bytes
WinMain(HINSTANCE__ * 0x00400000, HINSTANCE__ * 0x00000000,
char * 0x00141fea, int 1) line 33 + 21 bytes
WinMainCRTStartup() line 330 + 57 bytes
KERNEL32! 77f1b304()


source code : layout.c
-----------

------------------------------------------------------------
------------
The symbol ">>>>" show the line where it fails with
	state->list_stack -> NULL
------------------------------------------------------------
------------

	void lo_UpdateStateWhileFlushingLine( MWContext
*context, lo_DocState *state )
	{
	  int32 justification_remainder=0;

	  if (state->top_state->nothing_displayed != FALSE)
{
		/*
		 * If we are displaying elements we are
		 * no longer in the HEAD section of the HTML
		 * we are in the BODY section.
		 */
		state->top_state->in_head = FALSE;
		state->top_state->in_body = TRUE;

		lo_use_default_doc_background(context,
state);
		state->top_state->nothing_displayed = FALSE;
	  }

	  /*
		 * There is a break at the end of this line.
		 * this may change min_width.
		 */
	  {
		int32 new_break_holder;
		int32 min_width;
		int32 indent;

		new_break_holder = state->x;
		min_width = new_break_holder -
state->break_holder;
>>>>	indent = state->list_stack->old_left_margin -
state->win_left;
		min_width += indent;
		if (min_width > state->min_width)
		  {
		state->min_width = min_width;
		  }

Updated

20 years ago
Assignee: djw → toshok

Comment 1

19 years ago
toshok@netscape.com => toshok@hungry.com

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
Old bug, old codebase. Marking resolved.

Updated

19 years ago
Status: VERIFIED → REOPENED

Comment 3

19 years ago
Using the 1999042608 build, clicking on the Back button is again crashing the
browser. This was seen on Windows NT and Mac OS 8.5.1. No personal bookmark
folder was opened. Re-opening this bug to keep down on the total number of bugs
in bugzilla - if you'd prefer I open a new bug, please let me know.

Comment 4

19 years ago
Using the 1999042608 build, clicking on the Back button is again crashing the
browser. This was seen on Windows NT and Mac OS 8.5.1. No personal bookmark
folder was opened. Re-opening this bug to keep down on the total number of bugs
in bugzilla - if you'd prefer I open a new bug, please let me know.

Updated

19 years ago
Status: REOPENED → ASSIGNED

Updated

19 years ago
Resolution: WONTFIX → ---

Comment 5

19 years ago
*** Bug 7827 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Assignee: toshok → rickg
Status: ASSIGNED → NEW
QA Contact: petersen
Target Milestone: M7

Comment 6

19 years ago
I get a lot of dup bug on this...can we get this one fixed for M7 please?
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 7

19 years ago
Sigh. I'm very tired, and so I assume we all are. But this bug refers to the old
codebase -- not Mozilla. Since that point is made in the bug report, it seems
that I could have been spared some time if it had been read before getting
reassigned to me. Not a big deal really -- but it all adds up in the end.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

18 years ago
Blocks: 18687
You need to log in before you can comment on or make changes to this bug.