Sometimes ignores 'Do this automatically for files like this from now on'.

RESOLVED DUPLICATE of bug 285976

Status

()

defect
RESOLVED DUPLICATE of bug 285976
11 years ago
11 years ago

People

(Reporter: bridgess, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

When I download .torrent type file, sometimes Firefox opens 'What should firefox do with this file?' window even if I have checked 'Do this automatically for files like this from now on' box. And by 'open with' radio button there is only 'browse' button. But when i click OK then it downloads and opens like it should.

Reproducible: Sometimes

Steps to Reproduce:
No special steps. Just when i download these files a lot sometimes it opens the window, sometimes not.
Actual Results:  
Sometimes it opens the window.

Expected Results:  
It shouldn't have opened the window and simply downloaded and opened the file with specified program.
Such torrent files are often served up with content-disposition:attachment which means the browser has to ask what to do with the file. Unfortunately, firefox has a bug where it erroneously shows the "Do this automatically for files like this from now on", even tho firefox can't honour the setting.

So this is probably a dupe of bug 285976.
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 285976
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.