TinyMCE: source edit cause crash [@ nsDocShellEditorData::DetachFromWindow() ]

RESOLVED DUPLICATE of bug 430624

Status

()

--
critical
RESOLVED DUPLICATE of bug 430624
11 years ago
7 years ago

People

(Reporter: solarisciel, Unassigned)

Tracking

({crash})

Trunk
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042803 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042803 Minefield/3.0pre

TinyMCE 2.1.2 cause Minefield crash when apply and close in HTML source editor window.
Reproduced 20080428 nightly on Mac, Windows.

Reproducible: Always

Steps to Reproduce:
1. access admin page of this demo: http://www.opensourcecms.com/index.php?option=com_content&task=view&id=2101
2. selsect any document from the side "documents tree" bar.
3. Edit the document.
4. Click [HTML] from the TinyMCE toolbar(popup opens)
5. Click "update" in the popup window
6. Crash.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

11 years ago
Created attachment 318106 [details]
Mac crash report

Comment 2

10 years ago
Confirming - I reproduced this on Windows, at the official TinyMCE demo page, http://tinymce.moxiecode.com/example_full.php?example=true, as well as on my own server (with an older version of TinyMCE).

Alternative steps to reproduce:
1. Go to http://tinymce.moxiecode.com/example_full.php?example=true
2. Click HTML
3. Click Cancel (on the popup that appears)

Severity -> Critical as a reproducible crash bug that affects this very common editor.

Crash reports:
http://crash-stats.mozilla.com/report/index/68ae9ae6-16c0-11dd-b926-001cc45a2ce4
http://crash-stats.mozilla.com/report/index/df7bfb02-16c0-11dd-8b9e-001cc45a2c28
http://crash-stats.mozilla.com/report/index/ff7f4499-16c0-11dd-a7c1-001cc45a2c28
http://crash-stats.mozilla.com/report/index/0f4059f0-16c1-11dd-a9e8-001cc4e2bf68
http://crash-stats.mozilla.com/report/index/29abed54-16c1-11dd-a227-0013211cbf8a
http://crash-stats.mozilla.com/report/index/4b188447-16c1-11dd-a48c-001cc45a2c28
http://crash-stats.mozilla.com/report/index/fe94f88a-16c1-11dd-8d0b-001cc4e2bf68

I'm using: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008042906 Minefield/3.0pre ID:2008042906

P.S. This should perhaps be Product = Core, Component = Embedding: Docshell 
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: TinyMCE: source edit cause crash → TinyMCE: source edit cause crash [@ nsDocShellEditorData::DetachFromWindow() ]

Comment 3

10 years ago
Traced (using the hourly build archive at http://hourly-archive.localgho.st/) to this date range: http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1208986380&maxdate=1208993639 (http://hourly-archive.localgho.st/win32/20080423_1634_checkins.html). Builds before that don't exhibit the crash.

Bug 386782 is almost certainly the cause, as it affects DocShell.
Component: General → Editor
Depends on: 386782
Product: Firefox → Core
QA Contact: general → editor
do you also crash when you use the tryserver build from https://build.mozilla.org/tryserver-builds/2008-04-29_11:42-cpearce@mozilla.com-386782-regression_fix.v1.wip3.patch/ ? this build includes the patch from bug 386782.
Keywords: crash
Blocks: 386782
No longer depends on: 386782
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 430624
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsDocShellEditorData::DetachFromWindow() ]
You need to log in before you can comment on or make changes to this bug.