Closed Bug 431231 Opened 12 years ago Closed 12 years ago

Unable to save RSS feed to anything but the bookmarks toolbar (UI missing?)

Categories

(Firefox :: Bookmarks & History, defect, major)

defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 3

People

(Reporter: marcia, Assigned: mak)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042806 Minefield/3.0pre. Also seen on Windows.

STR:
1. Visit a site with an RSS feed, such as nytimes.com
2. Select the RSS icon
3. Select the "Subscribe Now" button

Expected: I should be able to save to Bookmarks Menu or some other location in places.

Actual: Only the name field is present, and the RSS feed defaults to saving on the Bookmarks Toolbar.

I think the "Create in" UI is somehow missing. That UI is present in the build from the 27th.
Flags: blocking-firefox3?
Regression Window:  Works using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008042704 Minefield/3.0pre.

Broken:  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008042806 Minefield/3.0pre
Severity: normal → major
Marco, could this be a regression from your patch on bug 428403?

All check-ins within this regression window: http://tinyurl.com/67w5ge
(In reply to comment #2)
> Marco, could this be a regression from your patch on bug 428403?

Once again and CC'ing Marco...

Flags: blocking-firefox3? → blocking-firefox3+
Assignee: nobody → mak77
(In reply to comment #3)
> (In reply to comment #2)
> > Marco, could this be a regression from your patch on bug 428403?

... but it doesn't explain the missing UI. 

no, the regression is from bug 425851
Blocks: 425851
Status: NEW → ASSIGNED
Attached patch patchSplinter Review
show always the folder picker when we are not in edit mode
Attachment #318340 - Flags: review?(mano)
Whiteboard: [has patch][needs review mano]
Whiteboard: [has patch][needs review mano] → [has patch][has reviews]
Comment on attachment 318340 [details] [diff] [review]
patch

a1.9=beltzner
Attachment #318340 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
Checking in browser/components/places/content/bookmarkProperties.js;
/cvsroot/mozilla/browser/components/places/content/bookmarkProperties.js,v  <--  bookmarkProperties.js
new revision: 1.87; previous revision: 1.86
done
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [has patch][has reviews]
Duplicate of this bug: 431450
verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9pre) Gecko/2008043007 Minefield/3.0pre ID:2008043007 and Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre)
Gecko/2008043013 Firefox/3.0pre
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 3
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.