Firefox prints pages using text-align: justify with mashed up fonts

RESOLVED DUPLICATE of bug 403513

Status

()

defect
RESOLVED DUPLICATE of bug 403513
11 years ago
11 years ago

People

(Reporter: mcepl, Unassigned)

Tracking

1.8 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008042509 Fedora/3.0-0.55.beta5.fc9 Firefox/3.0b5
Build Identifier: firefox-2.0.0.14-1.fc8 

(originally a Fedora bug https://bugzilla.redhat.com/show_bug.cgi?id=444630)

Firefox prints pages using text-align: justify with mashed
up fonts.  Firefox renders the pages properly on screen, but
its postscript rendering for printing mashes up the fonts as
shown in the attached postscript file.

An example webpage demonstrating the problem is at :

http://registrar.duke.edu/bulletins/undergraduate/2007-08/ugbhtml/UGBHTML-04-1.html

A very similar problem occurs in seamonkey but seamonkey actually renders
the on-screen page with mashed up fonts as well as the printed
rendering.  At least for the seamonkey issue, it is pango related
as compiling it without pango resolves the issue.  I haven't
recompiled firefox without pango to test the printing problem



Reproducible: Always

Steps to Reproduce:
1.print the page in question to a file
2.
3.
Actual Results:  
observe disaster

Expected Results:  
Nice printout, similar to the one from FF3.
Component: General → Printing
Product: Firefox → Core
QA Contact: general → printing
Version: unspecified → 1.8 Branch
works for me - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Note since this works in Firefox 3 the chances of this being fixed in a Firefox 2 update are very close to 0.
I can confirm this bug using an upstream binary of firefox 2.0.0.14 on fedora 8.

(Firefox 3 has other, new printing bugs, so it would be good if printing on ff 2 would be fixed, until firefox 3 becomes usable)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Kevin, which linux distribution did you use for your test?
What cairo/pango versions do you have installed on your system?

While I see the mashup problem in printouts on a Fedora 8 system,
the same upstream firefox 2.0.0.14 binary works fine on Fedora 9.
Using the Mozilla build of 2.0.0.14, Ubuntu 8.04, Pango 1.20.
It's a duplicate of 403513.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403513
You need to log in before you can comment on or make changes to this bug.