Invisible text in unnumbered list and formatting loss (boxes, colour)

RESOLVED DUPLICATE of bug 444723

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 444723
10 years ago
9 years ago

People

(Reporter: Anton Cox, Unassigned)

Tracking

1.9.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5

Various pages at www.city.ac.uk (including www.city.ac.uk/mathematics but *not* the similar top page) are corrupted. Side menus contain (mostly) invisible items, and various features such as highlighting boxes and colour schemes also vanish. The pages appear correctly in Firefox 2, and other browsers.

Reproducible: Always

Steps to Reproduce:
1. visit www.city.ac.uk/mathematics
2.
3.
(Reporter)

Comment 1

10 years ago
The problem is still present in RC1, and relates to incorrect loading of style files. The page contains the following two lines - if the first <link> line is deleted then everything works fine. The file city2col.css @import's another css file, and it is this which fails to load if the first line is left in. This is not a problem in FF2 or other browsers.

<link rel="stylesheet" href="http://www.city.ac.uk/global/css/city2col.css" type="text/css" media="sc#82;een,projection" />

<style type="text/css" media="screen,projection">
@import 'http://www.city.ac.uk/global/css/city2col.css';
/* Viewed in all but NS4 or earlier (PC/MAC), IE4 or earlier (PC), all IE (MACs only) */
</style>


(Reporter)

Comment 2

10 years ago
city.ac.uk have now redesigned their site so that the issue does not arise (although that does not resolve the underlying problem). However, visiting the sites listed no longer demonstrates a problem.

Comment 3

10 years ago
Anton, can you attach a simple testcase that demonstrates the bug?
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → style-system
Version: unspecified → 1.9.0 Branch
Ah, yes.  The two stylesheets pointing to the same uri with the first disabled thing.  This got fixed for Firefox 3.1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 444723
You need to log in before you can comment on or make changes to this bug.