Last Comment Bug 431613 - iframes src randomly copies other iframes srcs, better: the loaded page refers to another iframes src
: iframes src randomly copies other iframes srcs, better: the loaded page refer...
Status: RESOLVED DUPLICATE of bug 279048
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Windows XP
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://frohling.biz/fileadmin/tests/t...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-30 18:04 PDT by Niels Fröhling
Modified: 2011-01-12 07:08 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Niels Fröhling 2008-04-30 18:04:03 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Big explanation on the given page, compare with 2.0 for reference

Reproducible: Always

Steps to Reproduce:
1. Load the given page
2.
3.
Actual Results:  
dynamically created iframe loads wrong page?
static iframes load wrong pages?


Expected Results:  
show the correct page


reassigning the iframes srcs to itself fixes the issue, you'll get the report on that from the given page (alert before fix, so you may see it better)

i would say (without knowing the code-base) the iframes srcs are collected in a non-protected pending-downloads-list, or the locks position is slightly wrong, giving back the response from the request before or after
Comment 1 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-05-21 00:20:20 PDT
I tried to open that page in Fx2 and Fx3. Fx2 crashed, and Fx3 hanged.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008052006 Minefield/3.0pre

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Comment 2 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-06-16 08:08:28 PDT
For the record, Webkit render it messy but doesn't crash. Opera 9.5 and IE7 caused a blue screen of death...
Comment 3 Niels Fröhling 2008-06-18 10:22:22 PDT
My Opera crashed too, I assume it has to do with the Netscape-Style-Plugin of WMP, possibly the Plugin tries to take advantage of some NS-only feature.?

That your IE7 crashes is a surprise to me, that it shows a blue screen is near unbelievable. I havn't seen that except for corrupt hardware since years.

If you prefer I replace the video by a Quicktime-variant, in the hope your Quicktime-Plugin doesn't behave that way. Please let me know.
Comment 4 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-06-18 11:00:25 PDT
I was surprised as you. I never had a blue screen with Windows XP caused by a program execution. I have got a bit of nostalgia...

If you can replace the video with a Theora-Vorbis-Matroska version I feel better, since normally I use VLC and its mozilla plugin, if this isn't a problem for you :-)
Comment 5 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-06-18 11:03:32 PDT
Ah, I forgot to ask you: videos are necessary? Can't you embed some text pages, for example?
Comment 6 Brett Stime 2009-06-16 15:09:42 PDT
Dup of bug 279048?
Comment 7 chris hofmann 2009-09-16 22:19:44 PDT
I'm trying to load the test URL but getting time outs.  I think we need a test case attached or we might as well close or dupe against bug 279048
Comment 8 Carlos Alén Silva 2009-09-26 00:13:11 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090925 Shiretoko/3.5.4pre GTB5

Firefox suffered several multi-second hangs plus high CPU usage, finally Fx became responsive again. The page never stopped loading (spinning throbber) and the layout was broken, but at least, the page was browseable. 

Using Adblock Plus, Stylish - http://userstyles.org/styles/13864, and Flashblock.
Comment 9 Tyler Downer [:Tyler] 2011-01-03 20:30:52 PST
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You may also wish to try with the latest Firefox 4 beta, http://www.mozilla.com/en-US/firefox/all-beta.html.
Comment 10 :Ms2ger 2011-01-12 07:08:51 PST

*** This bug has been marked as a duplicate of bug 279048 ***

Note You need to log in before you can comment on or make changes to this bug.