"X" to close tab not always displayed

VERIFIED DUPLICATE of bug 359133

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 359133
10 years ago
10 years ago

People

(Reporter: Daniel Costalis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5

The "X" to close a tab is sometimes displayed on all windows, and sometimes not. 

Reproducible: Always

Steps to Reproduce:
1. Open multiple tabs
2. Close a tab with the "X" button
3. Click a link holding down system key to open in a new tab
Actual Results:  
When a tab is closed, the "X" appears on all tabs. When a new tab is opened, the "X" disappears from all tabs except current focus

Expected Results:  
The "X" button should either always be visible on all tabs, or never visible on all tabs.

Comment 1

10 years ago
This is intentional. The Xs disappear when you open "too many" tabs. You can tune the behaviour with browser.tabs.closeButtons in about:config (see http://kb.mozillazine.org/Browser.tabs.closeButtons ).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 359133
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.