set up rate-limiting and error injection proxy system to help with performance and reliability testing

RESOLVED DUPLICATE of bug 23459

Status

mozilla.org Graveyard
Server Operations
RESOLVED DUPLICATE of bug 23459
10 years ago
3 years ago

People

(Reporter: chris hofmann, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
bugs like bug 428726 and many others require testing with erract network conditions or slower connections in many case to reproduce the "real world" conditions that firefox use the browser under.   we used to have bandwidth rate limiting proxy set up to help with this kind of testing.   we should get that set up again.   if there are also proxy system that can inject errors or simulate poor connection it would be great to have that capability too.

litmus is really not the right component for this bug, but could find a general or other category that might be better.  feel free to change to better product/component.
Assignee: justin → server-ops
Component: Litmus → Server Operations
Product: Webtools → mozilla.org
QA Contact: litmus → justin
Version: Trunk → other
(Reporter)

Updated

10 years ago
Blocks: 428726
(Reporter)

Comment 1

10 years ago
justin mentioned "the cloud" as a possible choice.

this one looks pretty interesting too.  http://www.xk72.com/charles/wiki/features and sounds like the have some kind of firefox extension that goes along with it to control the server...

Comment 2

10 years ago
http://www.shunra.com/ - software was create when I used it last, but was some time ago.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 23459
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.