checking "do this automatically for files like this from now on" doesn't have any effect on future downloads of same file type

RESOLVED DUPLICATE of bug 285976

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 285976
11 years ago
11 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

Checking "do this automatically for files like this from now on" when
downloading any file type with a "Content-disposition: attachment" header line, doesn't have any effect on future downloads of the same file type with the same header. Firefox doesn't seem to "remember" my selection, even not in
the same session.

Reproducible: Always

Steps to Reproduce:
1. Download any file type with a "Content-disposition: attachment" header line.
2. Check the box near "do this automatically for files like this from now on".
3. Download the same file type again.

Actual Results:  
Download dialog box appeared again

Expected Results:  
Previously user-chosen Download/Open action should start automatically.

Reproducible: Always




More extensive details of this bug can be found in bug #331259, which was erroneously marked as verified fixed even though it was only fixed for some cases.

The bug still persists in all cases where the server sends a "Content-disposition: attachment" header line, even if the user has manually, explicitly set the desired behavior for the type of attachment and manually, explicitly told FF not to ask again when "Content-disposition: attachment" and that specific file type are received in the future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 285976
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.