[RFE] Embed timestamp as title of <td> element for "Opened" and "Changed" columns bug list

RESOLVED DUPLICATE of bug 425649

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 425649
10 years ago
10 years ago

People

(Reporter: BijuMailList, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

10 years ago
Embed the complete timestamp in the title of row <td> elements for "Opened" and "Changed" columns of query list
Version : https://landfill.bugzilla.org/ as of today

At present bugzilla.mozilla.org do sorting by javascript, this is a big saver as it is on client side (instead of server side as in bugzilla dev version).
But sorting gives incorrect order for columns "Opened" and "Changed" as it is pretty formatted to chop of time or date part appropriately.
If the complete timestamp is provided then that could have been used for sorting.

steps:-
* goto 
  https://bugzilla.mozilla.org/buglist.cgi?chfieldfrom=-1h&chfieldto=Now
* "Change Columns" to include "Opened" and "Changed" columns 
* click "Opened" column title 
* user see Opened column sorted incorrectly
* click "Opened" column title again
* user see Opened column sorted incorrectly in reverse order
* click "Changed" column title 
* user see Changed column sorted incorrectly
* click "Changed" column title again
* user see Changed column sorted incorrectly in reverse order

Expected: sorting should be proper


Example view-source: 
https://landfill.bugzilla.org/bugzilla-tip/buglist.cgi?query_format=specific&order=relevance+desc&product=&content=test
show only date-time as "Fri 11:41" for column "changed"

  <tr class="bz_bugitem
             bz_normal
             bz_P2
             bz_NEW
             bz_row_even">

    <td class="first-child">
      <a name="b5008"
         href="show_bug.cgi?id=5008">5008</a>
      <span style="display: none"></span>
    </td>

    <td style="white-space: nowrap">Fri 11:41
    </td>
    <td style="white-space: nowrap">nor
    </td>
    <td style="white-space: nowrap">P2
    </td>
    <td style="white-space: nowrap">fabi.emi&#64;gmail.com
    </td>
    <td style="white-space: nowrap">NEW
    </td>
    <td style="white-space: nowrap">
    </td>
    <td style="white-space: nowrap">Wind
    </td>
    <td >test
    </td>

  </tr>



==== expected ====
<td style="white-space: nowrap" title="2008-05-02 11:41:35 PDT" >Fri 11:41
</td>

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425649
You need to log in before you can comment on or make changes to this bug.