firefox profile is set to default with too many links in bookmark folder

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: baumber, Unassigned)

Tracking

2.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

This problem occurs under Windows (XP SP2) and Linux.

I have many links stored in the bookmark folder (also with subfolders, ...)
File Size bookmark.html: 2.17 MByte

When I sometimes start firefox, all preferences are set to default.
This problem was several times, and the bookmarks were still there and not lost.

So I copied a Backup into the Mozilla folder, that restores the settings.

This problem occurs very often, so I make a clean profile and setup the preferences by hand.

But the problem is still there, and now when it sets to default, the bookmark file is corrupted (only characters , the square, is in the file) --> Bookmark data is lost. That is in Windows XP SP2 (I also defragment the system, but that didn't solve the problem.)

First the problem wasn't under Linux (Gentoo Linux 2007.0), but after importing the working bookmark file to sync the bookmarks, the problem was there in the same way.

I have installed following themes/addons; iFox , NoScript, but when I uninstall these plugins, the problem is also there.

Is there a border of amount of links in bookmark.html, that I have reached?!

In common the error can appear after 3 days, or after 1 or 2 weeks, or on one day twice, I think that it depends on the frequency, I add bookmark links?.

Both Firefox Versions under Linux and Windows have the latest version (2.0.0.14)

Best regards, B.A.


Reproducible: Sometimes

Actual Results:  
bookmark data is lost!

Expected Results:  
Load in the stored bookmarks.
can you provide clear steps to reproduce your problem, like
1. ...
2. ...
3. ...
?
Severity: critical → normal
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> can you provide clear steps to reproduce your problem, like
> 1. ...
> 2. ...
> 3. ...
> ?
> 

The error is sometimes, and it depends on my bookmark file. 
That's why I cannot give clear steps to reproduce.
For example, you can copy many links (> 2000 ) into the bookmark.html file and test it, if firefox corrupts it.

But currently the problem doesn't occur at me for 1 month, although I changed nothing on my system.

So I set the bug status to "Resolved - WORKSFORME".

Best regards, B.A.
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.