[1.8 branch] List to the right of left-floated objects are rendered incorrectly

VERIFIED DUPLICATE of bug 262195

Status

()

--
major
VERIFIED DUPLICATE of bug 262195
11 years ago
10 years ago

People

(Reporter: huji.huji, Unassigned)

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

In a page which is right-to-left, when an image is added, and is floated to left using CSS, and some text is added next to it, it is expected that the text should be rendered to its right. However, as you can see here:

http://test.wikipedia.org/wiki/Float_bug

That image causes the text to get kicked out of its place. A similar bug exists which is solved on Wikimedia wikis by adding a line saying:

UL { display: block; }

however, this solution doesn't work in this case.

The same page renders correctly in Internet Explorer and Opera.

Reproducible: Always

Comment 1

11 years ago
I can reproduce the bug where text goes outside the table in

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

but works fine in

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008050416 Minefield/3.0pre
Component: General → Layout: BiDi Hebrew & Arabic
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout.bidi
Hardware: PC → All
Summary: List to the right of left-floated objects are rendered incorrectly → [1.8 branch] List to the right of left-floated objects are rendered incorrectly
Version: unspecified → 1.8 Branch

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 262195
(Reporter)

Comment 3

11 years ago
With further investigation it became clear to me that this bug is exactly the same as bug 262195. Until Firefox 3.0 is releaseed, the workaround is to use:

 UL { display: table; } 
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: layout.bidi → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.