If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash in SQLite [@ syncJournal ]

RESOLVED DUPLICATE of bug 428550

Status

()

Toolkit
Storage
--
major
RESOLVED DUPLICATE of bug 428550
10 years ago
10 years ago

People

(Reporter: Kai Liu, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
I encountered a random crash this morning that was mostly out-of-the-blue.  My breakpad ID:
http://crash-stats.mozilla.com/report/index/f62d890f-19e5-11dd-9dc7-001321b13766

Every crash in this function in the Breakpad database (#80 on the crasher list) has happened at the same place:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/db/sqlite3/src/sqlite3.c&rev=1.18&mark=23100#23100

There does not appear to be an entry for this bug in the SQLite bug tracker, and the following is the only other reference to the problem that I have been able to find is this:
http://www.mail-archive.com/sqlite-users@sqlite.org/msg29637.html

Since there seems to be no other mention of this problem, I doubt that this is something that had been fixed between 3.5.4 and the current release.  So... should I (or someone else more familiar with SQLite) file a bug in SQLite's bug tracker?

STR: Unfortunately, this seems to be random.
I've sent mail to the sqlite list about this [1].  Looks to me like it's happening when we try to close a transaction.

[1] http://www.mail-archive.com/sqlite-users@sqlite.org/msg33691.html

Comment 2

10 years ago
Seems like this might be a duplicate of
https://bugzilla.mozilla.org/show_bug.cgi?id=428550
yup - looks right to me
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428550
You need to log in before you can comment on or make changes to this bug.