Closed Bug 432201 Opened 15 years ago Closed 15 years ago

Browser hangs when opening the Help menu and subsequently crashes when closing

Categories

(Firefox :: Menus, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 426499

People

(Reporter: brunogirin, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-GB; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-GB; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

When clicking on the top level Help menu, the browser hangs and never opens the menu. Top level menus can't be opened anymore although the browser itself is still usable but very slow as it uses close to 100% CPU. When closing the browser using Apple+Q, it crashes.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox and check CPU usage under normal usage
2. Click top level menu other than Help
3. Click top level Help menu
4. Check Firefox CPU usage
5. Close Firefox using keyboard shortcut (Apple+Q)
Actual Results:  
Step 1. CPU usage is average (~30%)
Step 2. Top level menus other than Help work
Step 3. Help menu doesn't open when clicked
Step 4. Firefox CPU usage is now at 95%+ and top level menus are no longer accessible
Step 5. Firefox takes a long time in closing and eventually crashes

Expected Results:  
Step 3. Help menu should open and work as normal
Step 4. Firefox CPU usage should still be normal and all menus should work
Step 5. Firefox should close normally

The bug occurs with a the default theme. I will provide a Talkback crash ID when possible.
I just reproduced and referenced this bug report in the Talkback crash details.
Flags: blocking-firefox3?
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 426499
Flags: blocking-firefox3?
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.