Multiple parallel forms asking for the master password when starting

RESOLVED DUPLICATE of bug 369963

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 369963
10 years ago
10 years ago

People

(Reporter: Kevin Richter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

I have enabled the FIPS module, because a few addons do require this:
For example the "Nagios checker" and "Firefox Companion for eBay" store some passwords. And the "Session Manager" loads on startup some websites via SSL.

Every time I start Firefox I get asked for the master password twice.
Before the Firefox window opens, there are two seperate forms asking for the password.

It is really annoying. Can you fix it?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
You don't need to enable FIPS to use a master password. I'd be surprised if either of the two extensions required either FIPS or a master password, but I suppose it's possible.

In any case, this is flaw in the prompting architecture, and a duplicate of existing bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 369963
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.