Paste of bookmark on "Bookmarks Menu" in sidebar causes "Recently Bookmarked" folder to expand

VERIFIED FIXED in Firefox 3.1a1

Status

()

P2
normal
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: abillings, Assigned: mano)

Tracking

Trunk
Firefox 3.1a1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
If a user copies a bookmark via context menu or keyboard in the bookmarks sidebar and then pastes on the "Bookmarks Menu" folder, the "Recently Bookmarks" folder will expand open when closed.

This was found in build Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008050404 Minefield/3.0pre.

Steps to Reproduce
1. Bookmark a page into the "Bookmarks Menu" folder.
2. Open the Bookmarks Sidebar (make sure the "Recently Bookmarked" folder is collapsed).
3. Right click on the bookmark just added and choose copy.
4. Right click on the "Bookmarks Menu" folder and choose paste.

Result: Bookmark is pasted and "Recently Bookmarked" folder expands.

I moved the "Recently Bookmarked" folder around (to see if it was just that the first folder opens) and, regardless of position, the "Recently Bookmarked" folder will be expanded to show its contents when the bookmark is pasted in.

Comment 1

11 years ago
wfm on windows, still valid on mac?
I can reproduce this. This happens because the paste-command code tries to select the pasted node (per its itemId), and finds it under "Recently Bookmarked" query before it reaches it under the bookmarks menu folder itself. I don't think this, or any other select-post-command scenario  should recourse into folders at all.
Created attachment 328213 [details] [diff] [review]
patch
Assignee: nobody → mano
Status: NEW → ASSIGNED
Attachment #328213 - Flags: review?(dietrich)
Priority: -- → P2
Target Milestone: --- → Firefox 3.1a1
Comment on attachment 328213 [details] [diff] [review]
patch

r=me
Attachment #328213 - Flags: review?(dietrich) → review+
changeset e6ac4c25521f.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
I noticed this bug while running BFTs against 3.0.6. I can verify that it works now with:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090117 Shiretoko/3.1b3pre Ubiquity/0.1.4 ID:20090117020415

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090117 Shiretoko/3.1b3pre (.NET CLR 3.5.30729) Ubiquity/0.1.5 ID:20090117035052
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.