If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ICC-Profiled PNG not shown correctly

RESOLVED DUPLICATE of bug 418538

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 418538
10 years ago
10 years ago

People

(Reporter: Simone Ramacci, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5

When visiting test-pages like 
http://www.libpng.org/pub/png/colorcube/colorcube-pngs-iCCP.html
http://www.libpng.org/pub/png/colorcube/colorcube-pngs-iCCP-CSS.html
Firefox loads PNG images correctly but apply a sort of filter (maybe because it don't handle well ICC profiles) that makes the real color of the image different from the one it renders.

Reproducible: Always

Steps to Reproduce:
1.Visit one of the pages above with FF3b5
Actual Results:  
Pngs with colors like ffff99, ccffff are darker than the colors themselves.

Expected Results:  
PNG and background colors (both HTML and CSS) should be the same.

Comment 1

10 years ago
Do you have a color profile set? See http://kb.mozillazine.org/Gfx.color_management.display_profile for documentation.
(Reporter)

Comment 2

10 years ago
With color profile works fine.

(gfx.color_management.enabled;true)

Shouldn't ColorProfile be supperted in Firefox as default (like it is in Safari - i've read -)?

Comment 3

10 years ago
Well it is not enabled by default, bug 418538 - Enable color management support by default. Which might make this a dupe of that bug.

Comment 4

10 years ago
Yes, it's a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 418538
You need to log in before you can comment on or make changes to this bug.