Closed Bug 433093 Opened 12 years ago Closed 3 years ago

Cannot Drag & Drop into Pixelmator

Categories

(Core :: Widget: Cocoa, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: cottinghamk, Unassigned)

Details

(Whiteboard: p-safari)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9pre) Gecko/2008050901 Camino/2.0a1pre (like Firefox/3.0pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9pre) Gecko/2008050901 Camino/2.0a1pre (like Firefox/3.0pre)

Images cannot be dropped into Pixelmator's icon to open them. It does, however, work to drop them into Photoshop.

Reproducible: Always

Steps to Reproduce:
1.Open a page with just an image (or find an image on the page)
2.Click and drag
3.Drop into Pixelmator icon in dock
Actual Results:  
Nothing

Expected Results:  
Icon should highlight, dropping should open file in application
Sounds like Pixelmator isn't accepting the drag data we're giving it, which is likely to be a bug in Pixelmator.
Unless Firefox 3 can drag into Pixelmator, this should live in Widget:Cocoa anyway.
After a little bit of random poking, I tend to think there's a good chance that this is a Pixelmator bug. It looks like they want a promised file (the image they open is something from TemporaryItems). We do include a promised file in our drag, but Safari's is front-and-center, while ours in further down in the list of flavors.

We have a few other bugs about apps only looking at the first flavor on the pasteboard and making sure we put the image data before the url and urln/urld data, and maybe moving promised file to the head of the pasteboard, followed by the image data, would fix this.

Confirming because there is indeed a problem here, but it's possible it's not really ours and this might be INVALID.
Assignee: nobody → joshmoz
Status: UNCONFIRMED → NEW
Component: Drag & Drop → Widget: Cocoa
Ever confirmed: true
Product: Camino → Core
QA Contact: drag.drop → cocoa
Whiteboard: p-safari
Someone should probably give a heads-up to the Pixelmator devs about this bug.
I already did. I filed an identical bug report as soon as you pointed out that it was probably a Pixelmator bug.
Kevin, what have you heard from them about it so far? Anything?
Nope. I haven't gotten a single response.
See also bug 323555 of which this may be a dupe.
(In reply to comment #8)
> See also bug 323555 of which this may be a dupe.

Not if that bug's on Windows ;)

Someone who knows the Cocoa drag/pasteboard code should see if simply changing the order we put flavors on the pasteboard fixes this--or maybe this bug is just http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/widget/src/cocoa/nsDragService.mm&rev=1.33&mark=448#448
Assignee: joshmoz → nobody
This has been fixed, I just confirmed drag and drop from Firefox (53.0) to Pxelmator’s (3.6) dock icon works just fine.
Thanks, neekbeta! We changed the drag & drop API on OSX in bug 1235162. Based on this and comment 10, I'm going to close this bug as resolved.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.