Request for UDP server sockets in JS

RESOLVED DUPLICATE of bug 839757

Status

()

Core
Networking
--
enhancement
RESOLVED DUPLICATE of bug 839757
10 years ago
4 years ago

People

(Reporter: Dmitry, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Opera/9.50 (X11; Linux i686; U; en)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

It would be very nice to have an UDP server socket available from JavaScript, like nsIServerSocket as it shown in this example: http://www.xulplanet.com/tutorials/mozsdk/serverpush.php

Having only TCP sockets makes impossible to use XUL applications in some network clients, which requires UDP server.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

5 years ago
Component: Networking → WebRTC: Networking
QA Contact: jsmith
Not WebRTC...
Component: WebRTC: Networking → Networking
QA Contact: jsmith
UDP server sockets were added in bug 839757.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839757
You need to log in before you can comment on or make changes to this bug.