Tag container icon wrong when tag folder is empty

VERIFIED FIXED in Firefox 3.1b3

Status

()

VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: micmon, Assigned: mak)

Tracking

({polish, verified1.9.1})

Trunk
Firefox 3.1b3
x86
All
polish, verified1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
The tag folder uses the smart bookmark icon if it is empty, e.g. if you have not created any tags before. Tested with

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008051008 Minefield/3.0pre

and also confirmed for

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008051008 Minefield/3.0pre
(Reporter)

Comment 1

11 years ago
I can also confirm this on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre)
Gecko/2008050920 Minefield/3.0pre

so it affects all platforms (changing OS to all).

Note: after setting a tag you have to click the tag folder once to make it change.
OS: Linux → All
(Assignee)

Comment 2

11 years ago
that's because if hasChildren returns false we don't consider it a container, so we don't apply the correct icon since it requires the "container" attribute
(Assignee)

Comment 3

10 years ago
Created attachment 341287 [details] [diff] [review]
patch

see comment above
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #341287 - Flags: review?(mano)
(Assignee)

Updated

10 years ago
Whiteboard: [needs review mano]
(Assignee)

Updated

10 years ago
Whiteboard: [needs review mano]
Target Milestone: --- → Firefox 3.1
(Assignee)

Comment 5

10 years ago
pushed to trunk:
http://hg.mozilla.org/mozilla-central/rev/9287d4e1dd6f
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Attachment #341287 - Flags: approval1.9.1?
(Assignee)

Comment 6

10 years ago
Comment on attachment 341287 [details] [diff] [review]
patch

asking approval 1.9.1.
Polish fix, no risk.
(Assignee)

Updated

10 years ago
Keywords: polish
Attachment #341287 - Flags: approval1.9.1? → approval1.9.1+
(Assignee)

Comment 8

10 years ago
pushed to 1.9.1 branch:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/c026a7fe07d1
Keywords: fixed1.9.1
Target Milestone: Firefox 3.1 → Firefox 3.1b3
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090203 Shiretoko/3.1b3pre
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.