Last Comment Bug 433298 - EULA cut off checkbox/buttons on bottom - unusable on small (EeePC) screens
: EULA cut off checkbox/buttons on bottom - unusable on small (EeePC) screens
Status: VERIFIED FIXED
[RC2+]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: Firefox 3
Assigned To: Ed Lee :Mardak
:
Mentors:
: 433627 (view as bug list)
Depends on:
Blocks: 431713
  Show dependency treegraph
 
Reported: 2008-05-11 23:23 PDT by Ed Lee :Mardak
Modified: 2008-10-05 19:53 PDT (History)
10 users (show)
mbeltzner: blocking‑firefox3-
mbeltzner: wanted‑firefox3+
edilee: in‑litmus?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot of 18em 95ex (56.84 KB, image/png)
2008-05-12 06:08 PDT, Ed Lee :Mardak
no flags Details
sceenshot of trunk (30em 105ex) (60.57 KB, image/png)
2008-05-12 06:14 PDT, Ed Lee :Mardak
no flags Details
v1 (1.16 KB, patch)
2008-05-12 06:35 PDT, Ed Lee :Mardak
gavin.sharp: review+
mtschrep: approval1.9+
Details | Diff | Splinter Review

Description Ed Lee :Mardak 2008-05-11 23:23:41 PDT
Bug 431713 revved the EULA number, so it popped up when I tried upgrading beta 5 release to rc1.

The EeePC screen doesn't fit the whole EULA window, and even if you resize it, the checkbox and buttons aren't visible.

I had to ctrl-shift-tab from the beginning and hit space and enter until it was happy.
Comment 1 Ed Lee :Mardak 2008-05-11 23:29:04 PDT
chrome://browser/content/EULA.xul

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/browser/base/content/EULA.xul&rev=1.1&mark=69#69

<iframe style="min-height: 30em; min-width: 105ex" id="EULATextFrame" type="content" flex="1" src=""/>

Either reduce the min-height or get rid of it? But without it, it's possible that nothing shows up if the window is really really short..
Comment 2 Mike Beltzner [:beltzner, not reading bugmail] 2008-05-12 02:55:13 PDT
This isn't a regression, though the EeePC wasn't around when Firefox 2 was released. A good ride-along candidate, but I'm not sure it's an outright blocker on the release. If we do not block on this, we definitely need to fix it for the first branch release before we do major update.

Axel: is there an l10n impact to removing min-height?
Comment 3 Axel Hecht [:Pike] 2008-05-12 03:14:21 PDT
I don't think there's an l10n impact here, just a lot of "did you test on this screen and that platform".
Comment 4 aja+bugzilla 2008-05-12 03:15:29 PDT
Thanks, Mardak. Noticed this the other nite, but hadn't got around to filing
yet. Figured it was probably too late to block anyway, so there was no real
hurry.

If/when this is accepted, there's some minor probs with preferences menus that
probably should be filed as well.
Comment 5 Ed Lee :Mardak 2008-05-12 05:55:33 PDT
Well, as it stands right now, unless the EeePC user is clever enough to figure out how to get past the EULA without seeing the checkbox and button, s/he won't be able to use Firefox 3 (RC1).

On the EeePC I'm using.. changing the original "min-height: 30em; min-width: 105ex" to 18em and 95ex fits the screen.
Comment 6 Ed Lee :Mardak 2008-05-12 06:08:19 PDT
Created attachment 320535 [details]
screenshot of 18em 95ex
Comment 7 Ed Lee :Mardak 2008-05-12 06:14:22 PDT
Created attachment 320537 [details]
sceenshot of trunk (30em 105ex)
Comment 8 Ed Lee :Mardak 2008-05-12 06:35:49 PDT
Created attachment 320541 [details] [diff] [review]
v1

Quick fix for 30em -> 18em and 105ex -> 95ex.
Comment 9 Ed Lee :Mardak 2008-05-12 08:41:48 PDT
For RC1, people can do alt-c then press enter.. at least for the english locale.

I believe it's ctrl-shift-tab, ctrl-shift-tab, up, enter to get things working in general. (focus to cancel, focus to radios, change selection to accept, ok for dialog)
Comment 10 Mike Schroepfer 2008-05-12 08:46:40 PDT
eepc has a uncommonly tiny screen and there are ways for users to read the whole thing.  So we can't block RC1 for this.  If we have an RC2 we can take it there.
Comment 11 Ed Lee :Mardak 2008-05-12 08:51:30 PDT
(In reply to comment #10)
> there are ways for users to read the whole thing
The problem isn't reading the EULA. It's interacting with the window because the minimum height of the text is taller than the window, so the accept/not accept radios are off the screen in addition to the ok/cancel button.

Even if the user hits the maximize window button at the top, radios and buttons aren't shown.

The only other visible things to click are close and minimize.
Comment 12 Ed Lee :Mardak 2008-05-12 08:53:43 PDT
Like in attachment 320537 [details], if you click the maximize button at the top-right, it won't show anything different. Things aren't better even if you retract the taskbar at the bottom (black arrow at bottom-right).

You can drag the window around left/right/down, but it can't go any higher than the top of the screen.
Comment 13 Tony Chung [:tchung] 2008-05-15 14:37:50 PDT
*** Bug 433627 has been marked as a duplicate of this bug. ***
Comment 14 Tony Chung [:tchung] 2008-05-15 14:43:24 PDT
I am renom'ing this bug for blocking.   See comments in https://bugzilla.mozilla.org/show_bug.cgi?id=433627#c2 and https://bugzilla.mozilla.org/show_bug.cgi?id=433627#c3 for my arguments.  I think simply adding toolbars would fix things.
Comment 15 Mike Beltzner [:beltzner, not reading bugmail] 2008-05-15 15:22:02 PDT
Let's get the patch reviewed and ready to go along with an RC2 if we do one, but I don't think this bug on its own requires that we spin another candidate. It'll be an easy take for 3.0.1, though, and we can try to recommend it for the patchsets that various Linux vendors include in their pre-installed versions.
Comment 16 :Gavin Sharp [email: gavin@gavinsharp.com] 2008-05-22 18:30:55 PDT
Comment on attachment 320541 [details] [diff] [review]
v1

This makes it a bit harder to actually read the EULA on large screens, but who does that anyways? :)
Comment 17 Mike Schroepfer 2008-05-22 18:42:22 PDT
Comment on attachment 320541 [details] [diff] [review]
v1

a+ schrep per dev.planning thread to land on CVS trunk.
Comment 18 Ed Lee :Mardak 2008-05-23 00:25:45 PDT
Committed to both hg (mozilla-central) and cvs.

http://hg.mozilla.org/mozilla-central/index.cgi/rev/79924d3b5bba
remote: added 1 changesets with 1 changes to 1 files

changeset:   15143:79924d3b5bba
tag:         tip
user:        Edward Lee <edward.lee@engineering.uiuc.edu>
date:        Fri May 23 02:17:25 2008 -0500
summary:     Bug 433298 - EULA cut off checkbox/buttons on bottom - unusable on small (EeePC) screens. r=gavin, a1.9=schrep

Checking in browser/base/content/EULA.xul;
/cvsroot/mozilla/browser/base/content/EULA.xul,v  <--  EULA.xul
new revision: 1.2; previous revision: 1.1
done
Comment 19 Bartłomiej Brzozowiec (BartZilla) 2008-05-24 12:43:25 PDT
(In reply to comment #16)
> (From update of attachment 320541 [details] [diff] [review])
> This makes it a bit harder to actually read the EULA on large screens, but who
> does that anyways? :)
> 

I do. I think it sucks, especially item 4. (http://mxr.mozilla.org/firefox/source/browser/EULA#16):

"4.  PRIVACY POLICY.  You agree to the Mozilla Firefox Privacy Policy, made available online at http://www.mozilla.com/legal/privacy/, as that policy may be changed from time to time.  When Mozilla changes the policy in a material way a notice will be posted on the website at www.mozilla.com and when any change is made in the privacy policy, the updated policy will be posted at the above link.  It is your responsibility to ensure that you understand the terms of the privacy policy, so you should periodically check the current version of the policy for changes."

So, I guess it means that:
1. Privacy policy is integral part of the EULA (so Privacy policy should be available to the user during installation -- it isn't now if user is off-line)
and
2. user should read Privacy policy form time to time, so, according to EULA, user should do the following:
  - turn on computer
  - run another browser, without so ridiculous EULA
  - using another browser go to http://www.mozilla.com/legal/privacy/
  - read it carefully and compare with previous version
  - if it is acceptable, THEN finally run Firefox.

So, in summary, it sucks. Solution is simple: disable by default so called safebrowsing by Google, then you wouldn't need so ridiculous EULA. (Of course it is not going to happen, since Google really wants to "protect" users of FF by default, but hey, at least I can tell that I tried to do something with this...)
Comment 20 :Gavin Sharp [email: gavin@gavinsharp.com] 2008-05-24 21:36:16 PDT
BartZilla, if you have problems with the EULA, please raise them in an appropriate forum (like the mozilla.dev.apps.firefox newsgroup). They're not related to this bug.
Comment 21 Tony Chung [:tchung] 2008-05-31 00:56:56 PDT
Verified fix on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0.   EULA displays correctly on a 800x600 mode. 

Note You need to log in before you can comment on or make changes to this bug.