Closed Bug 433515 Opened 12 years ago Closed 9 years ago

warning when building with gcc 4.3.0

Categories

(Firefox Build System :: General, defect)

x86
All
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ht990332, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [build_warning])

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008051111 Firefox/3.0pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008051111 Firefox/3.0pre

When building firefox with gcc 4.3.0, there is a huge number of warning like this:

warning: conversion to ‘PRUint16’ from ‘int’ may alter its value

This is pretty harmless since it continues to build fine but it is still nice to gradually fix this issue over time because it adds over 6MB to the my build log when compared to a build with gcc 4.2.2

Reproducible: Always
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Whiteboard: [build_warning]
I could not any such instance of warning message in the logs. Moreover this is quite a general bug and we are trying to locale and fix all the issues. Once we are finished with warning bugs, we will traverse the build logs and will (atleast try to) fix all the warnings.
So closing this bug now.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.