Can't handle multiple proxies in proxy autoconfiguration file

RESOLVED DUPLICATE of bug 366504

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 366504
10 years ago
10 years ago

People

(Reporter: Jyrki Pulliainen, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008041514 Firefox/3.0b5

If proxy autoconfiguration returns multiple proxies (eg. "SOCKS localhost:2000; DIRECT"), Firefox doesn't use the latter one if the first one(s) fail to connect.

This is not the behaviour that is documented in the proxy.pac docs[1]

[1] http://wp.netscape.com/eng/mozilla/2.0/relnotes/demo/proxy-live.html

Reproducible: Always

Steps to Reproduce:
1. Configure a proxy.pac file to return two proxies, first being something that doesn't exist and the second being "DIRECT"
2. Reload the proxy.pac in browser
3. Surf the web
Actual Results:  
Firefox can't connect

Expected Results:  
Firefox should use the DIRECT proxy and display the site correctly

I've mostly done the testing using socks proxies, but this seems to be universal for all kind of proxies in proxy.pac

Comment 1

10 years ago
related bugs: bug 366504 or bug 273258 (both unconfirmed).
Component: General → Networking
OS: Linux → All
Product: Firefox → Core
QA Contact: general → networking
Hardware: PC → All
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
I've propably missed those both when adding this, but I'm now marking this as a dupe of #366504
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 366504
You need to log in before you can comment on or make changes to this bug.