All-numeric channel names do not appear as links in chatzilla

RESOLVED FIXED

Status

Other Applications
ChatZilla
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Adam, Assigned: Gijs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.83])

Attachments

(1 attachment)

959 bytes, patch
James Ross
: review+
Details | Diff | Splinter Review
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: 0.9.82

Chatzilla does not recognize channel names that consist of only numbers as links, (e.g. #51 will show up for a chatzilla user as plaintext, not a clickable links).

Reproducible: Always

Steps to Reproduce:
1. Type a channel link using only numbers (i.e. #10) into chat window
2. 
3.
Actual Results:  
Chatzilla users do not see numeric channel name as link

Expected Results:  
Numeric channel names should appear as links.

Comment 1

9 years ago
The channel munger specifically ignores entirely numeric channel-like items, just as it does #define, #ifdef and a few other C/C++ syntax things.

I don't know why entirely numeric items are included and I don't want to change the list in too much of a hurry.

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 2

9 years ago
(In reply to comment #1)
> The channel munger specifically ignores entirely numeric channel-like items,
> just as it does #define, #ifdef and a few other C/C++ syntax things.
> 
> I don't know why entirely numeric items are included and I don't want to change
> the list in too much of a hurry.
> 

Actually, I'd go for line numbers referenced somewhere, and bug numbers. However, I don't really think that that particular problem is more important than this one. We should already disable the channel linkifier inside protocol'd links as well as bug links, and if we don't we should do so if we fix this, because otherwise bonsai and lxr links will be "fun".
(Assignee)

Comment 3

9 years ago
Created attachment 323372 [details] [diff] [review]
Patch

There we go. We test for inLink in there, and set it in protocol:, bug and email links, so I think we're safe.
Assignee: rginda → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Attachment #323372 - Flags: review?(silver)

Comment 4

9 years ago
Comment on attachment 323372 [details] [diff] [review]
Patch

r=silver providing you've tested all the types of munger that could be affected (normal links, mailto, etc.)
Attachment #323372 - Flags: review?(silver) → review+
(Assignee)

Comment 5

9 years ago
Checking in mozilla/extensions/irc/xul/content/mungers.js;
/cvsroot/mozilla/extensions/irc/xul/content/mungers.js,v  <--  mungers.js
new revision: 1.15; previous revision: 1.14
done
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Whiteboard: [cz-0.9.84]
(Assignee)

Updated

9 years ago
Whiteboard: [cz-0.9.84] → [cz-0.9.83]
You need to log in before you can comment on or make changes to this bug.