Closed Bug 433708 Opened 12 years ago Closed 12 years ago

windows debug slaves on mozilla-central do not properly dump sdleak.log

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bhearsum, Assigned: dbaron)

References

Details

Attachments

(1 file)

This is possibly related to bug 432338 though the symptoms are a little different. When running with '--shutdown-leaks sdleak.log' or '--shutdown-leaks=sdleak.log' I get a file with the shutdown leak information in it, but the filename is '????????????????????' (with a varying number of '?'s), instead of the specified filename. This is different than what's happening on fxdbug-win32-tbox, though I have a hunch the cause is the same.

I've looked at the trace-malloc code a bit and I'm lost, I could use some help here.
Attached patch possible patchSplinter Review
I haven't tested this yet, but you could give this a try.
Comment on attachment 320924 [details] [diff] [review]
possible patch

I'm testing this now.
sdleak.log seems to be fixed on Windows with this patch, yay :)
Attachment #320924 - Flags: review+
Pushed to mozilla-central.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Assignee: nobody → dbaron
... in changeset 111c20038fa667049218d2dbc0023f54a07098b4
And, for the record, the windows debug tinderbox went green.
Component: Release Engineering: Maintenance → Release Engineering
QA Contact: build → release
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.