Load offline applications from application cache by default

RESOLVED DUPLICATE of bug 442806

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 442806
10 years ago
10 years ago

People

(Reporter: Michael, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_2; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.1 Safari/525.18
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

When applications are cached for offline use, future page loads should be loaded from the cache directly. Since this does not occur, applications are retrieved via GET first and fail to load if the browser is not set to "work offline" and a network error occurs (server down, connection refused, etc). Application caches should not be limited to functioning only when the browser is set to work offline.

Reproducible: Always

Steps to Reproduce:
1. Load a page with a HTML manifest, allow application cache to be created
2. Disable host web server
3. Attempt to load cached application. 
Actual Results:  
General "Failed to Connect" error page is shown.

Expected Results:  
The cached application should be presented with an offline notification.

This deficiency is alluded to in (http://developer.mozilla.org/en/docs/Offline_resources_in_Firefox), though I could find no related CM artifact nor an explicit definition of how an offline server should be handled. 

WHATWG Offline Spec (4.7 Offline Web applications)
4.7.5.1. Changes to the networking model
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 74349
Personally I would say this is more duplicate of bug 442806 or bug 442812 where the application cache is fully introduced and preferred according to WHATWG spec. See patch https://bugzilla.mozilla.org/attachment.cgi?id=327848&action=diff#a/netwerk/protocol/http/src/nsHttpChannel.cpp_sec2 where application cache is always choose to load from when a page is an offline application.
Duplicate of bug: 442806
You need to log in before you can comment on or make changes to this bug.