Active Checkboxes and Radio buttons will be filled with gray, overlaying the checkmark

RESOLVED WORKSFORME

Status

Core Graveyard
Widget: Qt
RESOLVED WORKSFORME
10 years ago
a year ago

People

(Reporter: Kay Abendroth, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Bug Flags:
blocking1.9 -
wanted1.9.0.x -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008051202 Firefox/3.0

Go to a web site with check boxes and radio buttons. Check some of them and look how the active one does not show the checkmark unless it is not active any more.

See http://img88.imageshack.us/img88/17/activecheckboxlu0.png for an example.

It seems to happen only on Linux with Default theme, for me at least since Firefox 3 Beta 3.

Reproducible: Always

Steps to Reproduce:
1. Mark one checkbox. (It will be surrounded with a dotted rectangle which is completely filled with gray, no checkmark visible.
2. Click elsewhere, but not the current box.
3. The box is loosing focus and the checkmark gets revealed.
Actual Results:  
The active checkbox / radio button does not show the checkmark.

Expected Results:  
The active checkbox / radio has to show the checkmark.

Updated

10 years ago
Version: unspecified → 1.9.0 Branch
Michael, does it look familiar to you? Something you could have a look on?
That's a regression from Firefox 2. We need a regression range when it starts happening.
Keywords: regression
Whiteboard: [need regression range]

Comment 3

10 years ago
It could be because we're drawing the focus after we draw the checkbox. I had a patch before that would change this behaviour, but Benjamin Berg told me it was not necessary and to take it out.
(Reporter)

Comment 4

10 years ago
Regression was introduced between 2007/06/2007-06-25-04-trunk and 2007/06/2007-06-26-04-trunk.
(Reporter)

Comment 5

10 years ago
Created attachment 321373 [details]
XHTML page with radio buttons and checkboxes

Use this XHTML to test.
Should be happen due to the check-in of the patch on bug 385686.

I'm still not able to see this issue with the default theme of Ubuntu 8.04. I used the Ubuntu version of Firefox. Kay does it even happen there?
Blocks: 385686
Whiteboard: [need regression range]
Version: 1.9.0 Branch → Trunk
(Reporter)

Comment 7

10 years ago
I experienced this issue on Kubuntu 7.10 and 8.04. Not sure if Ubuntu is
unaffected. I'm not able to test Ubuntu in the next days. Maybe someone else can test on Ubuntu and Kubuntu to confirm.
Michael, this bug is QT only. I run a test with Kubuntu and the RC1 release candidate and I can confirm this issue.

This is a really annoying issue because users cannot see the checked states for check boxes and radio buttons.

Putting on the radar for the 1.9 release. Any chance to get this fixed in the final version?
Status: UNCONFIRMED → NEW
Component: Widget: Gtk → Widget: Qt
Ever confirmed: true
Flags: blocking1.9?
QA Contact: gtk → qt
Does this affect all GTK apps or just Gecko? Could it be a gtk-qt engine bug?
When I change the GTK style to e.g. Raleigh and don't use the QT one, the focused checkbox is displayed correctly.

But having the fact that it is a regression and as Kay said, it is working with 2007/06/2007 shouldn't this be an issue on our side?
Not necessarily. Can you answer comment #9?
Not a blocker.  May or may not be our issue, but not severe enough to block, especially if its been broken for a year without anyone noticing until now.  Can fix once we have a patch.
Flags: blocking1.9? → blocking1.9-
Kay, what other GTK applications are delivered with Kubuntu? I really don't know this distribution. Does it have Gimp? I think this should be a GTK application. Does it also have this issue?
(Reporter)

Comment 14

10 years ago
I installed Seamonkey ( http://packages.ubuntu.com/hardy/seamonkey-browser | Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9 ) which also uses GTK 2 and it did *not* have this bug. I really think this is caused by Core.
Created attachment 322089 [details]
Focus ring of a checkbox in Gimp

I also did a further test with Gimp. Running this application I noticed that the focus is not drawn around the checkbox but the description. So this is just a different behavior on our side.

Btw. this only affects webpages. XUL seems to correctly handle this part, e.g. within the preferences dialog. There it looks like the above screenshot.

Comment 16

10 years ago
I can confirm this bug on Kubuntu hard using the latest version of FF3.0 installed from kubuntu package on 12/6/2008
This disturbs the user experience. Could we fix this with the next release?
Flags: wanted1.9.1?
Flags: wanted1.9.0.x?

Comment 18

10 years ago
I'm seeing this on a Linux/Kubuntu machine. I've seen it both using the Default theme as well as PitchDark 3.0.2. 

As a temporary work around, I've found clicking somewhere else on the page (i.e., removing focus) will show the radio button or checkbox appropriately.

Linux kubuntu 2.6.24-19-generic #1 SMP Wed Jun 18 14:43:41 UTC 2008 i686 GNU/Linux
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0
Not wanted for 1.9.0.x, but it'd be good to get fixed in 1.9.1.
Flags: wanted1.9.0.x? → wanted1.9.0.x-

Comment 20

9 years ago
Let me tell you...  not being able to see if a checkbox or radio button is checked
is a horrible user experience.  I use FF 3.0.1 on Kubuntu (KDE).  Things worked fine on FF 2.1.16 and earlier, but quit working atfer I installed 3.0.1.

Instead of worrying about how and where the problem originates, whether it's a bug fix or a work-around for a bug elsewhere, could we please just get a fix for it so we can actually use checkboxes and radio buttons again?
(In reply to comment #9)
> Does this affect all GTK apps or just Gecko? Could it be a gtk-qt engine bug?

Roc, does my comment 15 answers your questino?
Henrik: I guess so.

Michael, Ian, Teune, any of you guys up to take a look at this?

Comment 23

9 years ago
I believe comment 3 hit the nail on the head. The focus just needs to be painted first.  For some reason the focus was designed to have a background color, and since we are painting the focus over the checkbox, we are hiding it.  I just worry that a fix like this is just going to flip the issue, and we'll have widgets that are painting with backgrounds and completely covering the focus indicator.

Comment 24

9 years ago
I'd like to second comment #20.  I'm also finding this extremely annoying.

Just put in a vote for making this a priority.  Since the focus was covering the vote box, I couldn't see whether or not it was checked, but it looks like my vote went in.  Ah, the irony.

Comment 25

8 years ago
Both Firefox bug 432050 and Firefox bug 424367 seem to be related/duplicates.

Updated

8 years ago
patches in bug 521582 seem to fix this
I cannot see this described issue anymore with Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20130720 Firefox/24.0 ID:20130720004002 CSet: 73c4cb1518bb on Ubuntu 13.04.

If you are still facing it please reopen the bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: wanted1.9.1?
Resolution: --- → WORKSFORME
(Assignee)

Updated

a year ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.