Seperators in the bookmark toolbar are too thin and pallid

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: jan.manthay, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008051206 Firefox/3.0

Screenshot shows the differences between Fx2 and Fx3: It is he same bookmarks.html. The sepperators in Fx cant nearly be seen.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
Show the seperators the way as in Fx2
(Reporter)

Comment 1

10 years ago
Screenshot is here:
http://img185.imageshack.us/img185/7108/resultatdw3.gif
(Reporter)

Comment 2

10 years ago
More Infos:
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008051206 Firefox/3.0


Steps to Reproduce:
1. Installed the build in a new directory
2. Opened the Profile Manager , created a new Profile
3. Started Fx
4. Added a seperator in the toolbar: looks like in the screenshot.

Comment 3

10 years ago
WFM.  Is this the default Firefox theme?  And what Windows theme are you using?
Version: unspecified → Trunk
Same here with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008051606 Minefield/3.0pre ID:2008051606.

Version: Trunk → 3.0 Branch
Sorry, meant WFM.
(Reporter)

Comment 6

10 years ago
The Problem is connected with the MS Zune Style for Windows XP. When I use XP Standard or the MCE Theme everything is OK.

Comment 7

10 years ago
Okay, I see.  Yea, toolbar separators are messed up on Zune in general; this is not a problem specific to Firefox.  If you look at the Windows Explorer toolbar, you'll see that the separators there become very faint--to the point of invisibility--too with Zune.  This affects everything on the system, so there's not much that Firefox could do about it, unfortunately.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

10 years ago
But it is better in Fx 2...

Comment 9

10 years ago
(In reply to comment #8)
> But it is better in Fx 2...
> 

That's because Firefox 2 didn't render toolbar separators natively.  So you could say that Firefox 2's toolbar separator rendering was incorrect and buggy, but it just so happens that on the Zune theme, that incorrect rendering looked better because the native Zune rendering is itself messed up.

You can force a non-native rendering by adding the following to your userChrome.css:

toolbarseparator {
  -moz-appearance: none !important;
}

More information about userChrome.css can be found here:
<http://support.mozilla.com/en-US/kb/Editing+configuration+files#userChrome_css>
Due to it's not the fault of Firefox it should be INVALID.
Resolution: WORKSFORME → INVALID
You need to log in before you can comment on or make changes to this bug.